Jump to content

Recommended Posts

I am not sure if this is OK to have my very first post promoting some product here,

but I think it qualifies as a DIY, open source, community project.


I am mainly interested in getting some feedback about this badusb device that I made:




So, please let me know what do you think about this project.

Link to comment
Share on other sites

  • 2 months later...

Oh, somebody actually posed a reply. Hello.

Your feedback is welcome, especially if you are building these yourself.

I am kind of busy working on a redesign of my GPS logger project, but I

am very much planning to get back to work on PocketAdmin soon enough.

Maybe add some features like mouse control or bootloader for easy

firmware updates. And maybe you will have some other ideas too.

Link to comment
Share on other sites

I am not a great expert on how openocd works, but it might be a configuration file problem.

Are you using the makefile from the repository? and which OS are you doing this on?

You might try to run the flashing command from the makefile by hand, and change path or

names of the config files to something more appropriate for your system.

Link to comment
Share on other sites

I think I found the problem. My cheap St-link v2 turned out to be a CH340 ttl serial adapter. I'll let you know how it goes when I get a working one.

I was about 75% done making my own USB Rubber ducky, but abandoned it due to time constraints, and finding another project that did some of what I wanted. I was going to use a hardware MicroSD reader for speed, and was looking into a serial port to allow some feedback on the running script. Also, I was going to have the ability to run multiple scripts, as well as have one script call another. I really like your OS fingerprinting idea. I'm looking forward to playing with that.

Link to comment
Share on other sites

Well, I got a proper ST-Link V2, but get the exact error. I'm running Kali in a VM on Windows, and I'm thinking there might be a problem with the USB passthrough. I tried the Windows version of openocd under Windows, but couldn't get that to work either.

This is what I got in Kali:

root@kali:~/Desktop/PocketAdmin-master/firmware# make upload
openocd -s ./openocd -f stlink-v2.cfg -f stm32f0x.cfg -c "program firmware.bin verify reset exit 0x08000000"
Open On-Chip Debugger 0.8.0 (2014-10-20-21:48)
Licensed under GNU GPL v2
For bug reports, read
Error: session's transport is not selected.
Runtime Error: embedded:startup.tcl:20:
in procedure 'script'
at file "embedded:startup.tcl", line 58
in procedure 'swj_newdap' called at file "./openocd/stm32f0x.cfg", line 34
in procedure 'transport' called at file "/usr/share/openocd/scripts/target/swj-dp.tcl", line 26
in procedure 'ocd_bouncer'
at file "embedded:startup.tcl", line 20
Makefile:23: recipe for target 'upload' failed
make: *** [upload] Error 1


This is what I got while experimenting under Windows:

C:\temp\OpenOCD-20190828-0.10.0\bin>openocd -s ./openocd -f stlink-v2.cfg -f stm32f0x.cfg -c "program firmware.bin verify reset exit
Open On-Chip Debugger 0.10.0 (2019-08-28) [https://github.com/sysprogs/openocd]
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
stm32f0x.cfg:37: Error: target requires -dap parameter instead of -chain-position, see http://visualgdb.com/support/chainposition
in procedure 'script'
at file "embedded:startup.tcl", line 26
at file "stm32f0x.cfg", line 37


Link to comment
Share on other sites

Well, the cause is not immediately apparent from this. I probably will investigate that at some point.

But actually, I think I never had a software problem to result in flashing errors.  Every time

I got an error with openocd it was some hardware reason, like shorted pins or pins that look

like they are connected but are actually not and things like that.

So I would suggest to first of all try and take off the MCU, then place it back. Then try to flash again.

Maybe add some more solder with the soldering iron (while MCU is on board) . Repeat that procedure

a couple of times if necessary, and the problem could very well be solved. At least it always worked for me.

Tell me then if you were successful with that.

Link to comment
Share on other sites

  • 5 months later...

OK, it's been a while. I am posting here because there
was a new 1.3 revision of the device released recently,
with a lot of new cool features added. I have also posted
a couple of new videos on my youtube channel about it,
so if anybody is interested, you should check it all out.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...