Jump to content

RChadwick

Active Members
  • Content Count

    57
  • Joined

  • Last visited

Everything posted by RChadwick

  1. Since Mousejack type of attacks can be accomplished with a reprogrammed Logitech Unifying USB adapter, is this something we'll see in the future?
  2. Well, I got a proper ST-Link V2, but get the exact error. I'm running Kali in a VM on Windows, and I'm thinking there might be a problem with the USB passthrough. I tried the Windows version of openocd under Windows, but couldn't get that to work either. This is what I got in Kali: root@kali:~/Desktop/PocketAdmin-master/firmware# make upload openocd -s ./openocd -f stlink-v2.cfg -f stm32f0x.cfg -c "program firmware.bin verify reset exit 0x08000000" Open On-Chip Debugger 0.8.0 (2014-10-20-21:48) Licensed under GNU GPL v2 For bug reports, read http://openocd.sourceforge.n
  3. I think I found the problem. My cheap St-link v2 turned out to be a CH340 ttl serial adapter. I'll let you know how it goes when I get a working one. I was about 75% done making my own USB Rubber ducky, but abandoned it due to time constraints, and finding another project that did some of what I wanted. I was going to use a hardware MicroSD reader for speed, and was looking into a serial port to allow some feedback on the running script. Also, I was going to have the ability to run multiple scripts, as well as have one script call another. I really like your OS fingerprinting idea. I'm looki
  4. Thanks for sharing this! I'm almost done, but I fail at uploading the firmware to the device, getting a 'Error: session's transport is not selected.' Any ideas?
  5. I'm making one. I'm waiting for the regulator to arrive, but all the other parts are placed. Eager to see how it works.
  6. That might fix the SD card issue, but it breaks the 'I want three radios' issue.
  7. Maybe I just don't understand the problem, but considering one could run their own DNS server, I see absolutely no reason for the limitation, which is one of the main reasons my Pineapple collects dust. Even a $3 ESP8266 can do an Evil Portal without Internet, which is where I put my interest nowadays.
  8. The firmware was updated to 4? Any idea where there might be a changelog?
  9. I've got a Lan Turtle on v2 firmware. I am unable to add modules (Same error message as others have posted), so I'm trying to upgrade to V3. Problem is, no matter what I do, after the upgrade it doesn't work, and the USB end keeps disconnecting every 25 seconds. I have tried holding the button, and uploading V3 Factory firmware. I've also tried SCP the firmware to /tmp, and running the update command. The results are always the same.
  10. I'm looking for a way to gather a list of all nearby clients, including MAC addresses. In Linux, I do this: airodump-ng wlan0 -a --manufacturer --output-format CSV --write Open- However, I wanted to add Deauth to see if that would speed up things. Not wanting to add a 2nd Wifi adapter, I decided to dust off my Nano and see what it could do. Looking around, I don't see a clear way to do this. I can do a recon, but results are iffy, and I don't see a way to save the output. Ditto for the Site Survey module. Forgetting deauth for a moment, is the anything on the Nano that will save a list
  11. Any updates? After my Pineapple collecting a few months of dust, I decided to fire it up today. I'm running the non-beta available in the package manager. For whatever reason, Ep couldn't see any of my portals. Not sure if the Symlink disappeared. Anyway, was going to just uninstall, and reinstall. What should I reinstall? Is the beta running OK? Any ETA on 3.0?
  12. Is there a way to get Site Survey to reveal hidden SSIDs?
  13. Love the changes. I'm anxious to try this out as well! Also, as a feature request, it would be great if EP could control other plugins and Nano configs (Change network, SSID, start PineAP, DNSSpoof, etc). That way we could make a single package that we just need to enable.
  14. Silly question, but can DNSSpoof be run from command line? I wanted to make an Evil Portal that would automatically activate DSNSpoof, hoping I can do it from PHP. Thanks!
  15. Thanks for the help. I've got another issue. If I connect to the EP, and try to go to aol.com, the portal shows up fine. However, if I go to a more complicated page, such as what Windows tries to go to when it detects a portal (go.microsoft.com/fwlink/?LinkID=246412&clid=0x412), I get the page minus any graphics. When I try to view any of the images, it just shows the webpage again, minus the graphics.
  16. You're right, PHP error. I modified php.ini and easily saw and corrected the errors. Another quick question... Are the files for the portal critical? For instance, I have my own php file that handles form input. Do I have to use myportal.php? Best I can tell, the only important thing is the portalname.ep file.
  17. I've got an odd issue. I've got a HTML page that I renamed to index.php. It works fine in XAMPP, but not in EP (Just get blank screen). If I rename the index.php back to index.htm, and make sure there is no index.php in the directory, EP seems to pick up the index.htm, and everything works fine. Will this workaround be OK? Will future versions of EP force only using index.php?
  18. The symbolic link seems to work good. Still, would be good if the plugin could do this.
  19. Is storing portals on SD still in the works? It seems I have to do a factory reset every week or so, and having them on SD would be extremely welcome.
×
×
  • Create New...