Jump to content
Ch4s3r

Bricked Ducky?

Recommended Posts

Hi,

my ducky worked fine for one day, then after plugging it out and in again it just stopped working.
It just lights up very shortly with a red led.
I then tried to flash a new firmware.
After that it just lights up with a permanent solid red led when plugged in and I'm not able to flash a firmware again.
Here is the output of my flashing process:

sudo dfu-programmer at32uc3b1256 erase --force
sudo dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem c_duck_v2.1.hex 
sudo dfu-programmer at32uc3b1256 reset
[sudo] password for User: 
Erasing flash...  Success
Checking memory from 0x2000 to 0x3FFFF...  Empty.
Error reading line 1.

Before flashing I removed the micro sd card.
Do you have any suggestions what else I could try?

Share this post


Link to post
Share on other sites

I found my mistake: https://github.com/emsec/ChameleonMini/issues/88#issuecomment-284179380

I downloaded the twin duck firmware with the following command:

wget https://github.com/hak5darren/USB-Rubber-Ducky/blob/master/Firmware/Images/c_duck_v2.1.hex

But this downloaded the html version and not the RAW hex file.
The correct command would be:

wget https://raw.githubusercontent.com/hak5darren/USB-Rubber-Ducky/master/Firmware/Images/c_duck_v2.1.hex

 

Share this post


Link to post
Share on other sites

I'm having some issues...I'm hoping I just failed to flash the twin duck properly. So you pull the SD card out. Hold the button as you slide the usb in. wait 5-10 seconds , than hit it with the

sudo dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem c_duck_v2.1.hex 
sudo dfu-programmer at32uc3b1256 reset

and that should work? As of right now I'm stuck with green and red flashing lights whenever I plug it in, and that I used a generic test inject.bin.

Any Idea would help, Thanks!

Share this post


Link to post
Share on other sites

@skitz0 I did this and got the same result, however both my inject.bin works and I am able to store files on the microSD card.  Is it supposed to flash green and red?  Everything seems to work fine.  Any issues after your last post?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...