Jump to content

WiFi Strength when using Kali


Exmix
 Share

Recommended Posts

So my WiFi card is the Realtek RTL8723BE. When i'm on my Windows Partition i get a normal signal and it works OK, but when I swithc to Kali, im kinda forced to use my TP-Link TL-WN722N adapter since it helps me get a better signal. I looked into and found the rltwifi_new, I have it installed and such, but that didn't help. I have my /etc/modprob.d/rtl8723be.conf to be "options rtl8723be ips=0 ant_sel=1 fwlps=0" but so far these are the only options i've found to "fix" this. Wondering here if anyone else has any ideas to help. Most other forums/Subreddits i've asked on I haven't gotten an answer from in about 2 weeks. =\

Link to comment
Share on other sites

I think you're going to be limited to what options there are based on the drivers for the card, and comparison between windows and Linux are not so much OS dependent as the drivers which make things work. Some cards have better support based on the drivers available for them.

Does the card have any power options under iwconfig? If not, probably not much you can do about signal other than line of sight and putting it in some kind of enclosure like a pringles can or soda can/dome reflector pointed at the router. Reflector behind the router to point back at you will help, even on windows side. 

 

 

Link to comment
Share on other sites

1 hour ago, digip said:

I think you're going to be limited to what options there are based on the drivers for the card, and comparison between windows and Linux are not so much OS dependent as the drivers which make things work. Some cards have better support based on the drivers available for them.

Does the card have any power options under iwconfig? If not, probably not much you can do about signal other than line of sight and putting it in some kind of enclosure like a pringles can or soda can/dome reflector pointed at the router. Reflector behind the router to point back at you will help, even on windows side. 

 

 

My iwconfig return this:

wlan0     IEEE 802.11  ESSID:"MyWiFi"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: MAC
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:5   Missed beacon:0

I have no issues when using the TP-Link TL-WN722N adapter but i'd rather not have to use that everywhere I go just to get a decent connection.

Link to comment
Share on other sites

You can try:

iwconfig wlan0 txpower 30

or

iw phy wlan0 set txpower fixed 30mBm

but know that the card might also get hot/overheat. Just curious if that resolves your throughput issues.

You're already using 20, which is probably more than enough, but not sure if this is honored on the card. Compare the same settings between both cards, see what is different, if anything, and maybe you can adjust the one card to match if there is a difference.

Link to comment
Share on other sites

3 hours ago, digip said:

You can try:


iwconfig wlan0 txpower 30

or

iw phy wlan0 set txpower fixed 30mBm

but know that the card might also get hot/overheat. Just curious if that resolves your throughput issues.

You're already using 20, which is probably more than enough, but not sure if this is honored on the card. Compare the same settings between both cards, see what is different, if anything, and maybe you can adjust the one card to match if there is a difference.

I'll give this a try later today when i'm home and such and post back the result.

Link to comment
Share on other sites

Alright so far it seems that

iwconfig wlan0 txpower 30

seemed to help a bit. Not SHOWING a much better connection but it seems a bit more stable. The 2nd command there "iw phy wlan0 set txpower fixed 30mBm" comes back an error "command failed: No such file or directory (-2)"

Here's the ifconfig of my TP-Link adapter

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.107  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::62e3:27ff:fe16:3dd  prefixlen 64  scopeid 0x20<link>
        inet6 2605:a000:122c:1ca:62e3:27ff:fe16:3dd  prefixlen 64  scopeid 0x0<global>
        inet6 2605:a000:122c:1ca:7083:f3fd:979b:b758  prefixlen 64  scopeid 0x0<global>
        ether 60:e3:27:16:03:dd  txqueuelen 1000  (Ethernet)
        RX packets 79  bytes 11394 (11.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 60  bytes 8957 (8.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Edited by Exmix
Link to comment
Share on other sites

Both those commands more or less do the same thing. only need to do the one that works. Also, iwconfig, not ifconfig, to show the wireless settings. Do some speed tests with both cards, and with the settings at default and with the power set to 30db, see if there is a difference. Stability usually tends to be the card and drivers supported, some are better than others on windows than they are on linux while others only work on windows or have limited capabilities on linux such as connectivity only and no injection or monitor modes. Some can't do AP mode either, while others might work in AP mode but not monitor mode, really just depends on the card and what is supported by what drivers are available.

Link to comment
Share on other sites

3 minutes ago, digip said:

Both those commands more or less do the same thing. only need to do the one that works. Also, iwconfig, not ifconfig, to show the wireless settings. Do some speed tests with both cards, and with the settings at default and with the power set to 30db, see if there is a difference. Stability usually tends to be the card and drivers supported, some are better than others on windows than they are on linux while others only work on windows or have limited capabilities on linux such as connectivity only and no injection or monitor modes. Some can't do AP mode either, while others might work in AP mode but not monitor mode, really just depends on the card and what is supported by what drivers are available.

Ah gotcha. and yeah my bad I forgot, im more use to doing ifconfig than iwconfig. here's the iwconfig of the TP-Link adapter.

wlan1     IEEE 802.11  ESSID:"MyWiFi"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: MAC   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:7   Missed beacon:0

Speed Test with the TP-Link adapter - 16.89Mbps down and 6.27Mbps Up(Normal speeds for my net)

Speed test with the RTL8723BE adapter at 20db - 6.83Mbps down and 6.09Mbps Up

When doing an iwconfig after I try the "iwconfig wlan0 txpower 30" command, it still says it's at 20. No changes. I just caught on to that.

Link to comment
Share on other sites

Look at the signal quality between those two cards. The slow one's noise is:

 Link Quality=46/70  Signal level=-64 dBm 

while the faster one's is

 Link Quality=70/70  Signal level=-35 dBm

So i think your second card, it's antenna is shit and you need to put that puppy in line of site to the router to see if that makes a difference. If it has an external antenna, adding an external should help. If no external antenna, that could be par for the course. After googling, this looks like an internal laptop card? Looks like Ali Express might have antenna solutions that could help boost the signal, but I have a feeling if you need 2 cards for use, get an extra TPlink to add to your mix and avoid the internal card, just my 2 cents.

The smaller the Signal level in dBm, the stronger your signal(less noise). The higher the number, the more noise and more than likely slower speeds, more dropped packets, interference, etc. Boosting that signal somehow is key, either by adding an antenna somewhere, or reflected enclosure(s) between the router and the card. Chalk it up to TPlink for the win, and RTL8723BE as just a shitty card.

 

edit: Found this on ebay. Not sure if you can just make your own antenna somehow to boost the signal

http://www.ebay.co.uk/itm/Dell-Wireless-Wifi-Card-0KJTH7-RTL8723BE-w-0T81WX-Desktop-Antennae-Free-Ship-/232448754275?epid=1970336001&hash=item361f068263:g:5BAAAOSwkr5ZkmR-

Edited by digip
Link to comment
Share on other sites

1 hour ago, digip said:

Look at the signal quality between those two cards. The slow one's noise is:


 Link Quality=46/70  Signal level=-64 dBm 

while the faster one's is


 Link Quality=70/70  Signal level=-35 dBm

So i think your second card, it's antenna is shit and you need to put that puppy in line of site to the router to see if that makes a difference. If it has an external antenna, adding an external should help. If no external antenna, that could be par for the course. After googling, this looks like an internal laptop card? Looks like Ali Express might have antenna solutions that could help boost the signal, but I have a feeling if you need 2 cards for use, get an extra TPlink to add to your mix and avoid the internal card, just my 2 cents.

The smaller the Signal level in dBm, the stronger your signal(less noise). The higher the number, the more noise and more than likely slower speeds, more dropped packets, interference, etc. Boosting that signal somehow is key, either by adding an antenna somewhere, or reflected enclosure(s) between the router and the card. Chalk it up to TPlink for the win, and RTL8723BE as just a shitty card.

 

edit: Found this on ebay. Not sure if you can just make your own antenna somehow to boost the signal

http://www.ebay.co.uk/itm/Dell-Wireless-Wifi-Card-0KJTH7-RTL8723BE-w-0T81WX-Desktop-Antennae-Free-Ship-/232448754275?epid=1970336001&hash=item361f068263:g:5BAAAOSwkr5ZkmR-

That's pretty much what I was going to go with. Well thanks for the help and input. I appreciate it, you're the only person to help shed some light on this issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...