Jump to content

Initial setup problems


Recommended Posts

I'm having some problems getting started with the Bash Bunny and after watching some YT videos, reading the Wiki and forums, I figured I'd start a new thread to see if some of you could set me straight. I'm using macOS 10.12.5.

Specifically, I am having no luck getting the Bunny to share my network connection. Here's what I've done so far:

- I can serial into the Bunny by using the Serial app on macOS. Works just fine. I ran ifconfig while connected via serial and only see the local adapter. I can configure eth0 but the Bunny forgets it after it's removed.

- The Bunny will show up in Serial as something that I can connect to. It also shows up in Finder. It does not show up under System Preferences --> Sharing so I cannot enable sharing there. There was a great forum post on this but I just couldn't get it to work.

- I've booted the Bunny on setting one with a payload file (payload.txt) that only includes the following line: ATTACKMODE ECM_ETHERNET. I did not use #!/bin/bash or a specific LED pattern, just that one line. This seems to do nothing. I also tried "ATTACKMODE RNDIS_ETHERNET STORAGE" (no quotes) but this didn't do anything either.

- I installed and ran Squid as specified in the Wiki. I can seemingly run Squid but ssh to results in a time out on port tcp/22.

- Since nothing has worked, I've also tried using bb.sh to try and set up the Bunny this way. When I do that, I am allowed to get to the confirmation of network info (basically do you want guided or manual and do you have iproute installed) but then the gateway and IP are set to blanks. When I set them, the script times out on step three (error on line 183) telling me to connect the Bunny to my computer.

So I feel like I've tried a lot of things here and I'm not even getting close. Any advice anyone has for me is sincerely appreciated. I feel like this shouldn't be this hard!

Thank you!


Link to comment
Share on other sites

First of all, upgrade to firmware 1.3 using the instructions on the Wiki.

Second of all, refer to this image:

Bash Bunny Switch Diagram

This is sometimes confusing for some, and it sounds like you are under the same influence (so to speak). Switch 1 is the furthest away from the USB end (which refers to switch1 folder). Switch 2 is in the middle, and Arming mode is the closest to the USB end.

Link to comment
Share on other sites

Thanks - firmware upgraded. Not sure how I missed that but thanks all the same.

Still having issues with the network sharing. The switch is in the right place but still no luck. I'll keep trying. Interestingly enough, the Bunny is "up" but only available over ports tcp/53 and tcp/3128.


Link to comment
Share on other sites

Port 53 is DNS usually, and 3128 is usually a proxy server or Squid server.

ECM_ETHERNET should give you another network adapter, allowing you to access over ethernet using screen or something like that. Otherwise try connecting to the BB over serial (instructions on Wiki).

RNDIS_ETHERNET is for Windows machines mainly.

I don't use Mac so I can't help you in terms of sharing internet, but I can say follow the instructions on the Wiki - but that's about it I'm afraid. You can always try changing the port to 3128 instead of 22, as you mentioned in your first post.

Details on instructions are here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...