Jump to content

Ducky Firmware Problems - Win7


letters
 Share

Recommended Posts

Hello All,

I've continuously racked my brain on this today and repeatedly come up with the same error, perhaps someone can assist. I've tried this on two different Win7 x64 devices.

I feel I've done everything mentioned in the tutorials available here but I know I'm missing something as this isn't working. 

My error occurs, and I've seen it on Darren's Git Page, Flashing Ducky, but the I haven't found the information there to help my case. 

I error out at the Opening Port stage with a ATLibUsbDfu: 3EB 2FF6 no device present - FAIL Could not open device. 

I feel some of the guides are incomplete, leaving pieces out that I notice people claim to work in various comments. 

For instance: Inside the x86 folder of the Atmel Signed Driver is the .sys and .dll, through comments I get the understanding that I'm supposed to rename one of these files then drop them into my syswow64 folder, but the [Tutorial] by Nick mentions none of this. Also, Nick's post and a post by Enjoy0001 slightly contradict themselves in a couple of areas. In Nick's guide, there's no mention at all of dropping the program.bat along with .hex file into the Atmel\Flip 3.4.2\bin folder but it appears that needs to be done to complete the next operation, and per Enjoy0001's he drops the two files into the directory before bin, Atmel\Flip\ 3.4.2. I've tried placing the files in both directories with no luck. 

I've tried saving the .sys and .dll to both my syswow64 drivers folder and my system32 drivers folder. Do I need to be copying/moving these files at all? 

Darren's resource explains this is a driver problem and it's resolved by pointing the driver location to the atmel driver folder manually. I believe I've done this but perhaps I'm not doing it correctly as it's not helped yet. 

In order to download the Atmel driver I had to take this process: I'd like to note that loading the Ducky into my PC while holding the button does not prompt a wizard as some say it does on occasion. My Process on Win7 Ent. x64: Device Manager > Right click at the top > Add legacy Hardware > Show All Devices > Have Disk > Point to Atmel > toggle atmel_flip.inf > toggle AT32UC3B > Install Finishes 

Is my process of driver pointing incorrect? 

After performing these steps as instructed in Darren's post, I get the same error: Load Device manager, Find Atmel USB Device(Shows Atmel USB Devices in Device Manager not DFU Device), Update driver, Manual Install, Point windows to Atmel unzipped. 

C++ Redist and Flip are installed on the devices. Firmware file: c_duck_v2.1.hex 

Guide in mention by Nick: 

 

Guide in mention by Enjoy0001: 

 

I feel I did my due diligence of crawling these forums and YT for resolve to this error before posting but I've had no luck. Thanks for any input. If I can provide any additional information, I'll see to it immediately. 

I'll try this firmware flashing on a Linux device and a Windows 10 device later tonight. I'll report back with the outcome, but either way it'd be nice to solidify this process on a windows device. 

 

Link to comment
Share on other sites

Same experience so far on a Windows 10 device. I believe I'm ignorant of where to to place the .dll and .sys files exactly. If anyone can provide some insight on that I'd greatly appreciate it. 

This Win10 Device is an I7 x64. 

From what I understand of the ReadMe, I place the libusb0.sys into system32/drivers and libusb0.dll into system32.dll. But I'm not sure this is correct. I'm thrown off with the All Architectures as many appear applicable but likely my misunderstanding. 

I've tried also placing the files in all other areas mentioned in the read me such as syswow64. 

Next I'll give this a shot on a Linux device but I know I'm missing something extremely obvious regarding these Window devices. 

Thanks for any input. 

Here is the contents of the Read Me: 

-------------------------------------------------------------------------------

libusb-win32-bin v1.2.2.0 (10/02/2010) - [Package Information]

ALL ARCHITECTURES:
  x86\libusb0_x86.dll: x86 32-bit library. Must be renamed to libusb0.dll
    On 64 bit, Installs to Windows\syswow64\libusb0.dll.
    On 32 bit, Installs to Windows\system32\libusb0.dll.

  x86\inf-wizard.exe: inf-wizard application with embedded libusb-win32
    v1.2.2.0 binaries.

X86 ONLY ARCHITECTURES:
  x86\libusb0.sys: x86 32-bit driver.
    Installs to Windows\system32\drivers\libusb0.sys

AMD64-INTEL64 ONLY ARCHITECTURES:
  amd64\libusb0.sys: x64 64-bit driver.
    Installs to Windows\system32\drivers\libusb0.sys

  amd64\libusb0.dll: x64 64-bit library.
    Installs to Windows\system32\libusb0.dll

IA64 ONLY ARCHITECTURES:
  ia64\libusb0.sys: IA64 64-bit driver.
    Installs to Windows\system32\drivers\libusb0.sys

  ia64\libusb0.dll: IA64 64-bit library.
    Installs to Windows\system32\libusb0.dll

-------------------------------------------------------------------------------------------

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...