Jump to content

I can't install my wifi drivers


eternalfire
 Share

Recommended Posts

Installing kmod-rt2800-usb (3.18.23+2016-01-10-1) to root...
Collected errors:
 * opkg_download_pkg: Package kmod-rt2800-usb is not available from any configured src.
 * opkg_install_pkg: Failed to download kmod-rt2800-usb. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package kmod-rt2800-usb.
If the above errors were only about a kernel version missmatch, please ignore them. The package was installed successfully.

I can't "ignore them" because my wifi usb card (Asus N300) doesn't works.

root@Win:~# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=, 480M

Ther's no driver...

Link to comment
Share on other sites

One more thing, of corse i have done update on opkg and you can see the repository configuration files:

root@Win:~# cat /etc/opkg/distfeeds.conf
src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base
src/gz chaos_calmer_packages http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/management
src/gz chaos_calmer_routing http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/routing

 src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/luci
 src/gz chaos_calmer_telephony http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/telephony
root@Win:~# cat /etc/opkg/customfeeds.conf
# add your custom package feeds here
#
# src/gz example_feed_name http://www.example.com/path/to/files
# Old feeds from previous image
# Uncomment to reenable

src/gz chaos_calmer_pineapple https://www.wifipineapple.com/nano/packages

sorry for my english :wacko:

Link to comment
Share on other sites

*cough*

[snip]
* opkg_install_pkg: Failed to download kmod-rt2800-usb. Perhaps you need to run 'opkg update'?
[snip]

Edited by cooper
Link to comment
Share on other sites

Emmm...

One more thing, of corse i have done update on opkg and you can see the repository configuration files:

root@Win:~# cat /etc/opkg/distfeeds.conf
src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base
src/gz chaos_calmer_packages http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/management
src/gz chaos_calmer_routing http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/routing

 src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/luci
 src/gz chaos_calmer_telephony http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/telephony
root@Win:~# cat /etc/opkg/customfeeds.conf
# add your custom package feeds here
#
# src/gz example_feed_name http://www.example.com/path/to/files
# Old feeds from previous image
# Uncomment to reenable

src/gz chaos_calmer_pineapple https://www.wifipineapple.com/nano/packages

sorry for my english :wacko:

Link to comment
Share on other sites

Fair enough. Since it says it can't download it, did you actually try to find it yourself? No, you didn't, because it took me all of 5 seconds to find it:

http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-rt2800-usb_3.18.20+2015-03-09-3_ar71xx.ipk

So it's in base, and it also shows the problem you have: The kernel you're running is too new. You run 3.18.23+2016-01-10-1 yet their supplied kernel module is for 3.18.20+2015-03-09-3 (as are all the other kernel modules, in fact).

Conclusion is that somehow you ended up with a kernel that's newer than what OpenWRT comes with, and you need to either revert to their old(er) kernel or get your source for your newer kernel to also provide these kernel module files.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...