Jump to content

clients not connecting after deauth (which seems to have affect on device)


rslub9
 Share

Recommended Posts

I've added my android mac address to 'allowed clients' and company's AP to allowed ssid. It looks like when i deauth my phone's wifi connection does get interrupted a bit, however it does not connect to the pineapple - it just reconnects eventually back up to the real AP. I have Associations and all the rest of the checkboxes ticked - so it's supposed to be turned on.



Is this because there's a password/encryption of wpa2? Does this only connect clients who are automatically probing for OPEN networks? If so- - what are people doing these days as open networks are pretty much a thing of past for anyone setting up wifi.. . .



thanks for help.




Link to comment
Share on other sites

Range and power has a bit to do with it. I don't know if this is your problem, but make sure your phone is seeing the Pineapple as the stronger of the two APs. If it is not, phone will go right back to the original access point. Given two APs with the same SSID, most devices will go for the stronger of the two.

  • Upvote 1
Link to comment
Share on other sites

Thanks for response. I'm doing this in my company so it's possible the AP is stronger - -but my phone/tab/iphone is within a couple of feet with the nano. Let me ask you this, so I don't keep wasting time - - 'should' they be connecting automatically even if the real AP is password protected/encrypted wpa?.. When I attempted to connect to pineapple manually connect I get a message about it being unsecure - could that obstacle be the reason it doesn't connect automatically on the deauth?.

Link to comment
Share on other sites

Not 100% but I think if you have previously authenticated with the AP it'll take priority in your devices settings, at least thats been the behavior with my devices, they'll always favor something that's been auth'd before, but it also comes back to signal strength. No idea about the insecure vs encryption, though that may play a role, someone with more experience should chime in... so I can be proven wrong, if I am :)

Let me ask you this, so I don't keep wasting time - - 'should' they be connecting automatically even if the real AP is password protected/encrypted wpa?.. When I attempted to connect to pineapple manually connect I get a message about it being unsecure - could that obstacle be the reason it doesn't connect automatically on the deauth?.

Link to comment
Share on other sites

Also. Death requires being on the same channel. So this is where paying attention to antenna and having an idea of how far the device will deauth. With a good panel antenna I can deauth from 50m. Picking the client up to my ap, well my ap, isn't broadcasting that far through walls. But panel antennas do. But then you need to get that sweet spot in the panel antenna ranges. So having a sense of what the equipment can and cannot do will help.

Link to comment
Share on other sites

Thanks for response. I'm doing this in my company so it's possible the AP is stronger - -but my phone/tab/iphone is within a couple of feet with the nano. Let me ask you this, so I don't keep wasting time - - 'should' they be connecting automatically even if the real AP is password protected/encrypted wpa?.. When I attempted to connect to pineapple manually connect I get a message about it being unsecure - could that obstacle be the reason it doesn't connect automatically on the deauth?.

The short answer is that is depends on the phone and the settings of that device. For a longer answer read on.

With some devices they will always ask you about an unsecure connection if the settings are configured to ask.

The fact that a device is not automatically connecting to a pineapple could be for a myriad of reasons. For instance, if the phone has never seen any of the access points the pineapple is offering, then the phone will likely not connect automatically. One advantage with using the Nano is that PineAP can persuade wireless devices to give up the SSIDs that device is searching for but there are times when even this can be problematic.

In the case of an iOS device, many will not connect if they go into sleep mode even if they are broadcasting wireless packets. Once someone wakes the phone, it will then connect but only if it's seen the broadcasted SSID before and only if the device's settings are configured to allow the automatic connection.

If a device is already connected to an AP, then you have to fight the other AP for the device's attention. Sometimes you lose that battle.

Because there are so many different wireless devices all with different settings, its hard to say the what your particular issue is. Only by reviewing your devices settings and knowing how it operates when associated and unassociated to an access point will you gain full understanding into the matter.

This may sound elementary and you may have already tried this but, I would suggest this course of action:

1. Associate your devices to your company's AP

2. Ensure that your company's AP is in PineAP's SSID list

3. Get far away from your place of employment (and preferably anyone else) bringing your devices and the pineapple.

4. Turn on the pineapple running PineAP fully weaponized and power on all your devices to see if they connect automatically or if they ask for user input.

It might even be a good idea to turn on all your devices first, allow the screens to go idle (dark), and then power on the pineapple. This way you will know if you can get them to connect even if they are "sleeping".

I have hooked devices that usually beat me 90% of the time and have struggled to connect instruments that should have been trivial. Your mileage may very.

Edited by Skinny
  • Upvote 1
Link to comment
Share on other sites

thanks for the input- I will try this, for my device.. . The ultimate goal would be to fool a separate non-associated device to connect without user intervention which seems not likely.. . but perhaps when I learned a little more I can figure out. . . will keep you posted- thanks again for the time to teach a little.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...