Jump to content

Friendica Ubuntu Server: APT-GET No Longer Works! Help please!


bytedeez
 Share

Recommended Posts

I have my Ubuntu 12.04 server set to static IP on my router and in /etc/network/interfaces i transferred my domain name from domain.com to my home IP (comcast) and my dns is set to use comcast as well:

/etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.0.0.211
netmask 255.255.255.0
gateway 10.0.0.1
dns-search http://www.comcast.com
dns-nameservers 75.75.75.75 75.75.75.76

I can confirm that my /etc/resolv.conf is picking up my dns

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 75.75.75.75
nameserver 75.75.75.76
search http://www.comcast.com

Not sure if it matter but here is my host file as well:

127.0.0.1       localhost
127.0.1.1       mysite.net
127.0.1.2       Social.mysite.net
10.0.0.211      mysite.net
10.0.0.211      Social.mysite.net

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

I can ping mysite.net and i can access it from the outside web. as well as security.ubuntu.com

but when i tried to do an apt-get update or install (when trying to install the postfix mail stuff for friendica)

I receive an Error issue with resolving:

root@hostname:~# apt-get update
Err http://us.archive.ubuntu.com precise Release.gpg
  Temporary failure resolving 'us.archive.ubuntu.com'
Err http://security.ubuntu.com precise-security Release.gpg
  Temporary failure resolving 'security.ubuntu.com'
Err http://us.archive.ubuntu.com precise-updates Release.gpg
  Temporary failure resolving 'us.archive.ubuntu.com'
0% [Connecting to us.archive.ubuntu.com]
 

I have also tried setting my DNS to use Google's but received the same resolving error.

I've been working on this for 3 days and still can't figure out why i can't resolve this resolving issue.

Any help would be GREATLY appreciated!

Link to comment
Share on other sites

I created a new and went back through the steps of setting up a static IP.

Meaning i set it up on the server side and set the IP to static within my router as well.

Something i noticed is when i log into my router's UI.

I can no longer see my server as a connected device.

This is strange because i can clearly see my test webpages externally.

EDIT:

ok after some playing around this is what i figured out:

I can manual set my IP to static in /etc/network/interfaces, while in my router keeping the IP dhcp and apt-get update works fine until i set up my FQDN in /etc/hosts.

Once i set my FQDN in /etc/hosts i loss the ability to use apt-get.

EDIT # 2 :

Instead of setting my FQDN to 10.0.0.211 as shown above, i can set it to

127.0.0.1  mysite.net localhost

And i can still access my site externally my going to mysite.net and use apt-get update.

From what i have read in the Ubuntu documentation this is a in correct configuration though.

Edited by bytedeez
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...