Jump to content

Mark IV and wpa_supplicant


Recommended Posts

I know this is simple but I cannot seem to find the answer anywhere.

I'm trying to connect to a WPA2 network via command line on the pineapple. I have done this countless times in Backtrack but for some reason when I try it on the pineapple I keep getting the following error:

Successfully initialized wpa_supplicant
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed
wlan0: SME: Trying to authenticate with 00:1e:58:f2:69:73 (SSID='Ours' freq=2462 MHz)
wlan0: SME: Authentication request to the driver failed

The code that I am using is this:

wpa_supplicant -B -D nl80211 -i wlan0 -c /tmp/wpa_config.txt -f /tmp/wpa_debug.txt

with the config file looking like this:

network={
	ssid="Ours"
	psk="Password"
}

I have tried using the driver "wext" which worked using the Alfa card 036H on Backtrack, but on the pineapple it does not work. I have searched the forums for "wpa_supplicant" and "Pineapple WPA" and gone through everything that came up and cannot find the problem. Any assistance would be greatly appreciated. Thanks in advance.

BTW I also downloaded the networkmanager infusion to see if I could find how it was done in there but I am not proficient in PHP so finding it was a fruitless effort

Link to comment
Share on other sites

I had this exact same problem.To fix this just go to the etc/config/wireless file and change the "option network lan" under "config wifi-iface" to "option network wan". Also make sure your wireless card is in managed mode not AP mode. For more information on setting this up check this out.

Edited by TylerCPU
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...