Jump to content

Noob Setup Question


Scrag
 Share

Recommended Posts

I am new to pineapple Mark IV and Im having trouble ethernet tethering it...Im sure its something im doing wrong. My routing skills are rusty. :) First of all I have enabled IP forwarding by adding a "1" to the file: /proc/sys/net/ipv4/ip_forward

Ive attached a fancy ms paint chart to show my setup. Is something set wrong? Do I need to add route(s)?

Thank You!

Scrag

PS...the internet on the Backtrack box works fine using wlan0

post-43836-0-87397700-1372728638_thumb.j

Edited by Scrag
Link to comment
Share on other sites

As told in the Wifi Pineapple book found here:https://www.dropbox.com/s/dr6sedfteu8atwq/hak5-mk4-book1e.pdf

while in Backtrack (Or Kali) type

wget http://wifipineapple.com/mk4/scripts/wp4.sh

to download the ICS script, run

chmod +x wp4.sh

to make executable, then run it as root.

Edited by airman_dopey
Link to comment
Share on other sites

Ah, I am reminded why I don't run the script. Here are the errors I get. At the end, it drops the ssh connection.

root@Pineapple:~# ./wp4.sh
./wp4.sh: line 4: tput: command not found
  _       ___ _______    ____  _                              __   
 | |     / (_) ____(_)  / __ \(_)___  ___  ____ _____  ____  / /__ 
 | | /| / / / /_  / /  / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \
 | |/ |/ / / __/ / /  / ____/ / / / /  __/ /_/ / /_/ / /_/ / /  __/
 |__/|__/_/_/   /_/  /_/   /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/ 
./wp4.sh: line 9: tput: command not found
./wp4.sh: line 9: tput: command not found
./wp4.sh: line 9: tput: command not found
  OWN the Network                            /_/   /_/       v2.1

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: 
Internet Gateway [192.168.20.1]: 
IP Address of Host PC [172.16.42.42]: 
IP Address of Pineapple [172.16.42.1]: 

./wp4.sh: line 65: tput: command not found
./wp4.sh: line 65: tput: command not found
./wp4.sh: line 65: tput: command not found
./wp4.sh: line 65: tput: command not found
./wp4.sh: line 65: tput: command not found
./wp4.sh: line 65: tput: command not found
     _ .           ___          \||/   Internet: 192.168.20.1 - wlan0
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
./wp4.sh: line 66: tput: command not found
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
./wp4.sh: line 67: tput: command not found
./wp4.sh: line 67: tput: command not found
./wp4.sh: line 67: tput: command not found
./wp4.sh: line 67: tput: command not found
./wp4.sh: line 67: tput: command not found
./wp4.sh: line 67: tput: command not found
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0
Link to comment
Share on other sites

Im still having an issue unfortunately. Its with my backtrack laptop. Everything pineapple-wise works, but Ive found the problem is my laptop insists on using eth0 for internet (which my pineapple is tethered), instead of wlan0 for internet. Any ideas how to change the default adapter for internet would be greatly appreciated.

Ive done some research on this and tried using the route command to change the default gateway and a few other things but have not gotten it to work.

Thanks,

Scrag

Link to comment
Share on other sites

Isn't this the issue where disabling the network manager (wicd) or going in and removing the eth0 from being used/managed in wicd fixes his problem...?

edit:

http://forums.hak5.org/index.php?/topic/29612-clients-can-connect-but-cannot-surf/?hl=wicd#entry224221

Edited by thesugarat
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...