Jump to content

Alfa awus036neh Mac change

Recommended Posts

Hi All,

First time user here and before I ask my question I'd just like to say a big thankyou to all the people who have worked on the MKIV and the people who contribute to the forums and wikis. I bought myself an ap121u and flashed it in no time at all with little prior experience, couldnt have been easier.

I've used a script provided by lsc on these forums to get my internet tethering via wifi and an alfa dongle working great, apart from one thing. Doesnt seem to change the mac address of the above mentioned dongle. Ive tried doing it manually and also setting a mac as per below.

Ifconfig wlan1 down
macchanger -m 00:11:22:33:44:55 wlan1
ifconfig wlan1 up

Comes up with the error ERROR: Can't change MAC: interface up or not permission: Invalid argument after trying to change.

Any ideas? Im probably overlooking something simple. I havent tried changing wlan0 yet but i guess that will be fine, is it because im not using the supported dongle? Driver issue?

A point in the right direction or any help would be great. Thanks again


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...