Jump to content

Help Needed With My Mkiv And Arch Linux


Phyrne
 Share

Recommended Posts

Greetings! :)

I can't seem to get my MkIV working with my MacBook Air running Arch Linux.

Here's the situation: I have my Pineapple connected via ethernet (to eth0) from the PoE port, I wait a while after the WPS button stops flashing before trying anything.

Here's the output of 'ip addr' before I run the script:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 10:40:f3:89:c2:e2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.110/24 brd 192.168.0.255 scope global wlan0
    inet6 fe80::1240:f3ff:fe89:c2e2/64 scope link 
       valid_lft forever preferred_lft forever
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether b8:8d:12:56:b0:0b brd ff:ff:ff:ff:ff:ff

I run the wp4 script as root with all the default settings as these should suffice for my network:

     _ .           ___          \||/   Internet: 192.168.0.1 - wlan0
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0

Browse to http://172.16.42.1/pineapple  --  Happy Hacking!

Attempting to access the web gui at 172.16.42.1 shows that it is unreachable, so, here's ip addr after the script:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 10:40:f3:89:c2:e2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.110/24 brd 192.168.0.255 scope global wlan0
    inet6 fe80::1240:f3ff:fe89:c2e2/64 scope link 
       valid_lft forever preferred_lft forever
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether b8:8d:12:56:b0:0b brd ff:ff:ff:ff:ff:ff
    inet 172.16.42.42/24 brd 172.16.42.255 scope global eth0

And just in case, here's uname -a's output:

Linux MacBook 3.4.4-2-ARCH #1 SMP PREEMPT Sun Jun 24 18:59:47 CEST 2012 x86_64 GNU/Linux

Does anybody have any idea as to what I'm doing wrong?

Any help is greatly appreciated with this! Thanks in advance :)

Link to comment
Share on other sites

Odd, should work. What about manually configuring the network. Try "sudo ifconfig eth0 172.16.42.42 netmask 255.255.255.0 up; ping 172.16.42.1"

Also you may want to disable any network managers that might be messing with your connection. The network-manager service typically found in Gnome can sometimes get in the way. Not sure about arch but on ubuntu it's "stop network-manager".

Lastly, I did recently update the wp4.sh script to include some pretty ascii art and clean up the wizard a bit. I don't recall messing with the heavy lifting code but just in case here's a link to the old version. Let me know if this solves your problem as I haven't experienced trouble with the new one.

http://www.wifipineapple.com/wp4-1.0.sh

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...