Jump to content

Can Not Install Vlc


glprobot
 Share

Recommended Posts

hello all,

When I type apt-get install vlc

why am I getting this error?? how do I solve

apt-get install vlc-nox

Reading package lists... Done
Building dependency tree        
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gdebi: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed
         Depends: gdebi-core (= 0.8.5) but it is not going to be installed
         Depends: gir1.2-gtk-3.0 but it is not installable
         Depends: gir1.2-vte-2.90 but it is not installable
         Depends: python-gi but it is not installable
         Recommends: libgtk2-perl but it is not going to be installed
  network-manager-gnome: Depends: libgnome-bluetooth7 (>= 2.27.8) but it is not going to be installed
                         Depends: libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d) but it is not going to be installed
                         Depends: libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b) but it is not going to be installed
                         Depends: network-manager (>= 0.8~rc2) but it is not going to be installed
                         Depends: mobile-broadband-provider-info (>= 20090622) but it is not going to be installed
  network-manager-pptp: Depends: pptp-linux but it is not going to be installed
                        Depends: libnm-glib2 (>= 0.8~a~git.20090917t210753.fdb5ef2) but it is not going to be installed
                        Depends: libnm-util1 (>= 0.7.1~20090213+gitf142e15) but it is not going to be installed
                        Recommends: network-manager-pptp-gnome but it is not going to be installed or
                                    network-manager-pptp-kde but it is not going to be installed
  vlc-nox: Depends: liba52-0.7.4 but it is not going to be installed
           Depends: libass4 (>= 0.9.7) but it is not going to be installed
           Depends: libcddb2 but it is not going to be installed
           Depends: libdca0 but it is not going to be installed
           Depends: libdvbpsi5 but it is not going to be installed
           Depends: libdvdnav4 but it is not going to be installed
           Depends: libdvdread4 but it is not going to be installed
           Depends: libebml0 but it is not going to be installed
           Depends: libfaad2 but it is not going to be installed
           Depends: liblircclient0 but it is not going to be installed
           Depends: libmatroska0 but it is not going to be installed
           Depends: libpostproc51 (>= 4:0.5.1-1) but it is not going to be installed or
                    libpostproc-extra-51 (>= 4:0.5.1-1) but it is not going to be installed
           Depends: libswscale0 (>= 4:0.5.1-1) but it is not going to be installed or
                    libswscale-extra-0 (>= 4:0.5.1-1) but it is not going to be installed
           Depends: libtwolame0 but it is not going to be installed
           Depends: libupnp3 (>= 1.4.3) but it is not going to be installed
           Depends: libvcdinfo0 (> 0.7.23) but it is not going to be installed
           Depends: libvlc2 (>= 1.0.0~rc) but it is not going to be installed
           Depends: libvlccore2 (>= 1.0.2) but it is not going to be installed
           Depends: libx264-85 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Link to comment
Share on other sites

Prejudice.

I tried adding the repository:

add-apt-repository ppa:lucid-bleed/ppa
The program 'add-apt-repository' is currently not installed.  You can install it by typing:
apt-get install python-software-properties

after which I tried to install this:

 apt-get -f install python-software-properties
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gdebi: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed
         Depends: gdebi-core (= 0.8.5) but it is not going to be installed
         Depends: gir1.2-gtk-3.0 but it is not installable
         Depends: gir1.2-vte-2.90 but it is not installable
         Depends: python-gi but it is not installable
         Recommends: libgtk2-perl but it is not going to be installed
  network-manager-gnome: Depends: libgnome-bluetooth7 (>= 2.27.8) but it is not going to be installed
                         Depends: libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d) but it is not going to be installed
                         Depends: libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b) but it is not going to be installed
                         Depends: network-manager (>= 0.8~rc2) but it is not going to be installed
                         Depends: mobile-broadband-provider-info (>= 20090622) but it is not going to be installed
  network-manager-pptp: Depends: pptp-linux but it is not going to be installed
                        Depends: libnm-glib2 (>= 0.8~a~git.20090917t210753.fdb5ef2) but it is not going to be installed
                        Depends: libnm-util1 (>= 0.7.1~20090213+gitf142e15) but it is not going to be installed
                        Recommends: network-manager-pptp-gnome but it is not going to be installed or
                                    network-manager-pptp-kde but it is not going to be installed
  python-software-properties: Depends: unattended-upgrades but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried another way:

 apt-get -f install python-software-properties --fix-missing
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gdebi: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed
         Depends: gdebi-core (= 0.8.5) but it is not going to be installed
         Depends: gir1.2-gtk-3.0 but it is not installable
         Depends: gir1.2-vte-2.90 but it is not installable
         Depends: python-gi but it is not installable
         Recommends: libgtk2-perl but it is not going to be installed
  network-manager-gnome: Depends: libgnome-bluetooth7 (>= 2.27.8) but it is not going to be installed
                         Depends: libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d) but it is not going to be installed
                         Depends: libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b) but it is not going to be installed
                         Depends: network-manager (>= 0.8~rc2) but it is not going to be installed
                         Depends: mobile-broadband-provider-info (>= 20090622) but it is not going to be installed
  network-manager-pptp: Depends: pptp-linux but it is not going to be installed
                        Depends: libnm-glib2 (>= 0.8~a~git.20090917t210753.fdb5ef2) but it is not going to be installed
                        Depends: libnm-util1 (>= 0.7.1~20090213+gitf142e15) but it is not going to be installed
                        Recommends: network-manager-pptp-gnome but it is not going to be installed or
                                    network-manager-pptp-kde but it is not going to be installed
  python-software-properties: Depends: unattended-upgrades but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I went to look in system-> preferences-> if there is the synaptic packager manager , I also tried to install but nothing to do

How can I fix this???

Link to comment
Share on other sites

Hello,

I also tried the "sudo"

workaround see what happens:

 sudo apt-get -f install python-software-properties
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gdebi: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed
         Depends: gdebi-core (= 0.8.5) but it is not going to be installed
         Depends: gir1.2-gtk-3.0 but it is not installable
         Depends: gir1.2-vte-2.90 but it is not installable
         Depends: python-gi but it is not installable
         Recommends: libgtk2-perl but it is not going to be installed
  network-manager-gnome: Depends: libgnome-bluetooth7 (>= 2.27.8) but it is not going to be installed
                         Depends: libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d) but it is not going to be installed
                         Depends: libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b) but it is not going to be installed
                         Depends: network-manager (>= 0.8~rc2) but it is not going to be installed
                         Depends: mobile-broadband-provider-info (>= 20090622) but it is not going to be installed
  network-manager-pptp: Depends: pptp-linux but it is not going to be installed
                        Depends: libnm-glib2 (>= 0.8~a~git.20090917t210753.fdb5ef2) but it is not going to be installed
                        Depends: libnm-util1 (>= 0.7.1~20090213+gitf142e15) but it is not going to be installed
                        Recommends: network-manager-pptp-gnome but it is not going to be installed or
                                    network-manager-pptp-kde but it is not going to be installed
  python-software-properties: Depends: unattended-upgrades but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

or:

sudo apt-get -f install python-software-properties --fix-missing
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gdebi: Depends: python (>= 2.6.6-7~) but 2.6.5-0ubuntu1 is to be installed
         Depends: gdebi-core (= 0.8.5) but it is not going to be installed
         Depends: gir1.2-gtk-3.0 but it is not installable
         Depends: gir1.2-vte-2.90 but it is not installable
         Depends: python-gi but it is not installable
         Recommends: libgtk2-perl but it is not going to be installed
  network-manager-gnome: Depends: libgnome-bluetooth7 (>= 2.27.8) but it is not going to be installed
                         Depends: libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d) but it is not going to be installed
                         Depends: libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b) but it is not going to be installed
                         Depends: network-manager (>= 0.8~rc2) but it is not going to be installed
                         Depends: mobile-broadband-provider-info (>= 20090622) but it is not going to be installed
  network-manager-pptp: Depends: pptp-linux but it is not going to be installed
                        Depends: libnm-glib2 (>= 0.8~a~git.20090917t210753.fdb5ef2) but it is not going to be installed
                        Depends: libnm-util1 (>= 0.7.1~20090213+gitf142e15) but it is not going to be installed
                        Recommends: network-manager-pptp-gnome but it is not going to be installed or
                                    network-manager-pptp-kde but it is not going to be installed
  python-software-properties: Depends: unattended-upgrades but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

why????

Link to comment
Share on other sites

VLC and 10 million different plugins for it should be available via Ubuntu Software Center. Python 2.6 also comes installed by default in Ubuntu so you shouldn't need to be installing that either, something doesn't sound right.

What version of Ubuntu are you using?

When was the last time you updated?

Link to comment
Share on other sites

Hi bobbyb1980,

In practice I've done well in my Pc 3 partitions, I have 3 operating systems: Windows7, Ubuntu 4.12 with latest updates, Backtrack 5 r2.

I think I have to reinstall backtrack 5 r2, being that I get from these problems!

What do you think???

Link to comment
Share on other sites

Hi all,

Right now I have solved the problem:

1) Initially, what I first installed backtrack 5 r2, I installed version DEFAULT

2) Now, I rinstallato DEFAULT version, everything works.

3) Now, I can learn and start using Backtrack, you have any suggestions where I can start??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...