Jump to content

Sshfs On Markiii


telot
 Share

Recommended Posts

Good afternoon everyone!

On this lovely rainy memorial day weekend, I'm trying to get my old MarkIII to be useful once more. My brother recently moved in with us for the summer, and think it'd be a great public service for me to educate him and his friends about the dangers of open wifi connections. My MarkIII has been sitting collecting dust for past several months, since the markIV came into town, so I thought I'd hook up the markIII to my internal network and have it on all the time - maybe even come up with a "Wall of Shame" kind of deal - showing the kids the urlsnarf/ngrep/whatever data I cap'd off them. Thats all well and good - I changed the network settings on the markIII to match my internal network and whatnot and its happily karma'ing up victims left and right. Now comes the problem.

I'd of course like to tcpdump all the traffic on eth0, but the markIII is so short in the storage department, I thought hey! what a great application of sshfs! Unfortunately when I do a

opkg update

opkg install sshfs

It comes back with an error:

Collected errors:

* satisfy_dependencies_for: Cannot satisfy the following dependencies for sshfs:

* kernel (= 3.3.7-1-607db4585f74c0eb4be22dc576d44e8e) *

* opkg_install_cmd: Cannot install package sshfs.

Any idea on how to fix this? I googled my ass off and came back with squat.

Thanks for any help guys, as always

telot

Edited by telot
Link to comment
Share on other sites

And with "--force-depends" option ?

opkg install sshfs --force-depends

I did not try myself, just an idea :)

I took your advice WM - thank you. I got it installed by now it stalls with a Fuse error telling me to modprobe fuse (to which I insmod fuse - got no errors - but lmsod shows no fuse still!). Heres the command I'm trying to run:

sshfs -o ssh-command="ssh -p 2222" telot@internalIP: /root/telot

Very frustrating stuff...I'm half thinking about just buying another mark4 for the extra features anyways...lol this might be my impetus

telot

Link to comment
Share on other sites

Ok - the pragmatic side of me kicked in and settled for an ssh pipe instead of sshfs. I did a

tcpdump -i eth0 -n net 192.168.1.0/24 | ssh -p 2222 telot@internalIP "cat > /home/telot/pinecap.pcap" &

keep in mind I use port 2222 as my standard ssh port. It seems to be holding up now - it borked the mark3 at first, but thats probably because I was running everything under the sun (ngrep, urlsnarf, dnsspoof - etc).

Strange thing is, when I do this the pinecap.pcap on my cloud server isn't recognized as a valid file by wireshark. Very odd as all the data seems to be there. Any wireshark fanatics out there can maybe shed some light on why this may be?

telot

Edited by telot
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...