Jump to content

Windows 7 Microsoft Update Does Not Work


BlueWyvern
 Share

Recommended Posts

Hello all, I have a new issue that is stumping many a person around the world currently.

The unit in question is a Lenovo Y560 Laptop

Running Windows 7 Home Premium

The issue started with what I can only assume is a hard drive failure.

Purchased a new hard drive and ran the recovery discs that were created from the original install from factory.

had a thumb drive with some data from the old hard drive so after the install i inserted it and went to do updates and got the following message.

"Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer."

So after many Microsoft Fix Its, and some random results from lenovo's tech database I removed the Intel Storage Manager software and I still get the same issue.

Thinking it was perhaps Viral, I ran the restore again after a quick 0s DBAN wipe

Same old story sans the USB drive, ok so not viral....

Maybe the recovery CD is borked?

So I call in a favor from a friend to get a MSDN copy of a vanilla Win 7 install disc

long story short same thing.

ok so maybe ram is bad somehow?

run memtestx86 overnight, come back in the morning No ram errors.

so here i sit with the computer that works otherwise, just can't run windows update and can't install some other Microsoft products (like the latest .net framework or Service Pack 1)

Anyone seen this before or have ANY clue how to fix this?

other side note is that I have ensured that the service for windows update and all dependencies are all started/running

Link to comment
Share on other sites

Just fixed it, a response from another friend who had seen this before said to do the following

net stop wuauserv

C:\Windows\SoftwareDistribution\DataStore\Logs>del *.log

rename C:\Windows\SoftwareDistribution\ (look below)

Datastore > .old

Download > .old

SelfUpdate > .old

delete c:\windows\windowsupdate.log

net start wuauserv

and it is working again... I pray noone else has to try to figure this annoyance out, but good to have for reference

Link to comment
Share on other sites

I was going to offer you that solution, so looks like you are under control. Good work, keep it up!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...