Jump to content

Mk 2 - Various Questions And "problem"(s)?


Recommended Posts

A long time ago, in a galaxy far away, I purchased a magical pineapple from the wonderful providers of entertainment and hacking news/products at Hak5. I did NOT know what I was doing, and in my attempt to set up the pineapple I ended up killing it, and desecrating it's remains.

A few months, if not years, passed, and I tried yet again to set up my rather expensive bit of hardware. Here's what I've done so far:

1) Followed the guide for building/unbricking (here: http://hak5.org/hack/wifi-pineapple-flashing-guide)

2) Followed the "My first connection guide" (here: http://hak5.org/hack/wifi-pineapple-first-connect#comment-48620)

ALL OF THAT went off without a hitch, minus a missing dll and some minor connection problems. I was ecstatic, it was even less trouble than when I hacked my xbox. Now, I've run into a problem that I have yet to see posted on this forum (and for which the search bar turns up no good results). Actually, it's more like I've run into two problems.

I have two computers, one running windows (vista), and another running linux (ubuntu 10.10). My Windows computer connects to the internet (NOT through the pineapple) just fine (when the pineapple is disconnected), but my laptop cannot connect to my default router no matter what, as long as the pineapple is on. Is this normal?

The other problem i have is this: Ignoring the last problem, I have been trying to set up the pineapple to work on the laptop using this tutorial: http://forums.hak5.org/index.php?showtopic=15200&st=0 . BEFORE (when my pineapple was fragged, because i didn't know the password anymore) when i tried to connect, i didn't get an error message. This time, I get a lengthy message stating some nonsense about a "man in the middle" attack, JUST before the terminal spits out a message reading: "Host key verification failed." Is this because I rebuilt the pineapple, and it has a new host key? If so, what is the new/default host key (i don't remember changing it)?

Sorry if someone else has posted this question somewhere else, just curious about this whole mess. Also, is there a way to setup the pineapple on windows? I would rather set it up on linux, but meh, whichever is easiest.

Link to comment
Share on other sites

Not sure about your first problem, maybe someone else with a mark2 can step in and help?

Your "pickle in the middle" problem is resolved by going into /home/youruser/.ssh/known_hosts and deleting the line that pertains to the pineapple. You can just delete all the lines, but leave the file too. Enjoy

telot

Link to comment
Share on other sites

Awww... I was SO DAMN CLOSE! I got everything set up like I thought it should be. Admittedly, I have never ssh'd through terminal before (i've always used ubuntu's nifty little ssh tool, which doesn't seem to work this time), but I thought I did everything correctly. Here's what I did:

1) ssh'd into pineapple (ethernet)

2) used the command vi /etc/config/dhcp to open the dhcp

3) edited the dhcp (i didn't save at the time, but i went back and fixed that. The damn tutorial i was on mentioned nothing about it, and the command Pico didn't work, so vi was what i was stuck with).

4) Edited the pineapple's other settings, saved, AND applied.

5) Connected to wireless. I assumed it autoed from wlan0, which I'll talk about in a second.

6) Tried to run the pineapple!

Failed at step six, although i guess i probably also failed on steps 3 and 5. xD Here's my terminal output when I go to run it:

Please enter Internet facing interface

If left blank Internet facing Network Interface will be set to wlan0

Please enter Internet facing interface, i.e. wlan0:

wlan0 is not a valid Network Interface please enter a valid NIC

Please enter Internet facing interface

If left blank Internet facing Network Interface will be set to wlan0

Please enter Internet facing interface, i.e. wlan0:

So, the question would be, where did I go wrong? I think it was step 5, because I fixed step 2 and it fixed nothing, same message. Well, at least I've got openwrt running, which is more than i could do a few years ago. If anyone could tell me how to fix this wlan0 error thing, I would be most appreciative! Google results for "wlan0 how to connect" and similar are... less than helpful. Thanks in advance for any help, you guys (well, telot, anyway) have been fantastic sports thus far! :D

Link to comment
Share on other sites

Ah! Fixed it. Apparently, eth1 was the name my computer assigned to my wlan card. Hehe... *facepalm*. Sorry for wasting all those posts!

If people with the same problem are reading this in the future, all I can say is, iwconfig/ifconfig.

The easy stuff is often overlooked. Just don't give up so easy :P. Helps build character and troubleshooting techniques in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...