Jump to content

Resolution In Backtrack 4


darkknecrotic
 Share

Recommended Posts

I'm running a Sony Vaio Laptop with an ATI HD 4650 gfx chip, the 16.4 inch display sports a native resolution of 1600x900.

My xorg.conf file in /etc/X11 is empty and the only resolutions available to me in backtrack are 800x600 and 640x480.

Can anyone help me get a resolution of 1600x900? I'll be more than happy to provide additional information if needed. Thanks.

Link to comment
Share on other sites

Is this a VM, Native Install, or Live Disc/thumb drive you are trying it on? (My fix was for the VM by the way)

Try smaller resolutions and a color depth of 16, see if that helps. If not, restore the original from the backups I mention to create first, but you should be able to manually run the xorg configuration setup to automatically detect everything if installed natively.

Xorg -configure

Just be sure to keep that backup copy of the original if you need to revert (although you mentioned it was empty, so probably not doing you any good at this point).

Your Video card might not be supported 100% (although I doubt that is the issue) and you might have to just use vesa mode(800x600) until you can get it figured out.

Are you using the latest BT4R2 or another version of BT4, such as BT4 Final or BT4 R1? They are each different with varrying level of support for hardware, but I can't imagine that video card not being able to support BT4. By the way, there are other settings in that file that are needed, I only highlighted the area to add additional monitor sizes as well as editing the grub file to not force the screen size on boot. If your xorg.conf file was completely empty to begin with, thats most likely a problem. If that was the case, copy the one off the live disc and then edit it for adding addtional modes of resolution but you probably have to run the xorg utility to set everything up.

Here is my entire xorg.conf but remember this was for a VM and won't work exactly the same on a native install, so monitor name, GPU, additional settings, etc, need to reflect your system:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
    Identifier  "VMware SVGA"
    Driver      "vmware"
EndSection


Section "Screen"
	Identifier	"Default Screen"
    Device      "VMware SVGA"
    Monitor     "vmware"
    # Don't specify DefaultColorDepth unless you know what you're
    # doing. It will override the driver's preferences which can
    # cause the X server not to run if the host doesn't support the
    # depth.

    DefaultDepth 24

    Subsection "Display"
        # VGA mode: better left untouched
        Depth       4
        Modes       "1440x900" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       8
        Modes       "1440x900" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       15
        Modes       "1440x900" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1440x900" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1440x900" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection

EndSection
Section "InputDevice"
  Driver "vmmouse"
  Identifier "VMware Mouse"
  Option "Buttons" "5"
  Option "Device" "/dev/input/mice"
  Option "Protocol" "IMPS/2"
  Option "ZAxisMapping" "4 5"
  Option "Emulate3Buttons" "true"
EndSection
Section "Monitor"
    Identifier      "vmware"
    VendorName      "VMware, Inc"
    HorizSync       1-10000
    VertRefresh     1-10000
EndSection

Link to comment
Share on other sites

I'm running BT4 Final..

I ran the live cd, and copied the xorg.conf from it, and added some modes but I still have the problem:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

    Subsection "Display"
        Depth       16
        Modes "1600x900" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes "1600x900" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1600x900" "1024x768" "800x600" "640x480"
    EndSubsection

EndSection

When I try to run the xorg utility, I get an error about fb0 not being a directory. Then is creates xorg.conf.new in root and when I try using it as my zorg.conf, I get the "no screens" error. This is a real pain in the ass. I would stick with the 800x600, but it really hurts my eyes. Thanks.

Link to comment
Share on other sites

BT4 Final is 2 versions below R2, and as such, try installing the latest, then see if the problem persists. Being that its outdated by many months, older kernel, etc, there probably are things missing or unsupported. My guess is, if it still persists with the R2 version, then you need to find a proper display driver for your machine.

Whatever you do, also make sure you get it from the real BT site: http://www.backtrack-linux.org/downloads/ as there are a lot of fake ISO's being put out on sharing sites. BT site was just attacked recently too, so know that people are trying to dilute the waters with bad versions, backdoors, malware, etc, so always get it from the BT site itself.

Edited by digip
Link to comment
Share on other sites

I just tried BT4 R2 from the official website, and unfortunately the problem persists. I guess I'll look up some tuts on installing display drivers. Thanks.

I would tell you to try their forums but they are down for maintenance at the moment and not sure when they plan on brining them back. Good luck, and if you do get it fixed, please reply here with the steps, files, links, etc. Then eventually I can get it added on the BT wiki and forums for others to help as well.

http://www.backtrack-linux.org/wiki/index.php/Basic_Usage#Starting_a_GUI_Environment

By the way, I think the fb0 issue is the frame buffer on boot but don't quote me on that. I'm not 100% sure but maybe adding it as a device might work. See here for similar issue:

http://www.linuxquestions.org/questions/linux-software-2/dev-fb0-no-such-file-or-directory-359219/

Edited by digip
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...