Jump to content

Can't Connect To Wifi Without Connecting Ethernet First.


Recommended Posts

I set up my fon back in 2008, forgot about it after a couple months and now I recently picked it back up.

I've always used it with an ethernet cable and ICS with no problems, but now I'm thinking about getting another wireless card and equipping the fon with a battery.

I don't have my second wireless nic yet, but I noticed that unless I connect the fon to my ethernet port first, I can't get on the wireless. Is this because by connecting it through my ethernet port ICS is assigning it an ip? If so, when I get my second wireless nic, I suppose I'll have to connect to an AP with ICS on before I can connect to the pineapple?

If I'm missing something here, please tell me. Thanks.

Link to comment
Share on other sites

Depending on whose setup instructions you follow depends on the state of the Fon when you power it up. My default firmware has the wifi off by default so you'll have to start with the ethernet cable connected and then enable wifi.

Link to comment
Share on other sites

Depending on whose setup instructions you follow depends on the state of the Fon when you power it up. My default firmware has the wifi off by default so you'll have to start with the ethernet cable connected and then enable wifi.

Well, I followed Darren's guide on 4x05. I'm a little confused. So every time I want to connect to it wirelessly I'll have to connect the ethernet first? Or is there a way to have it start up with wifi enabled?

I've been stuck on this for hours so a little point in the right direction would be greatly appreciated.

EDIT: I figured I'd add that the ssid brodcasts but I can't connect to it (wirelessly) unless I pop in the ethernet first, here's a picture of my wifi page in x-wrt

wifiv.png

Edited by darkknecrotic
Link to comment
Share on other sites

If you want it to autostart then check through the forums it is posted in a few places, it is something like

wpa_supplicant ath0 wlandev wifi0 wlanmode ap

iwpriv ath0 karma 1

ifconfig ath0 1.1.1.1 up

and you add it to the Jasager init script.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...