Jump to content

Torrent Client Not Unloading When Run From Vm


Charles
 Share

Recommended Posts

Hey,

I was trying to download a torrent of CentOS but, while it's downloading just fine, the upload is still at 0. I've tried the same torrent on another (physical) machine and it uploads fine there, so I'm guessing that it doesn't like running inside a virtual machine.

Anyway.. the setup I have is this:

Ubuntu 10.04 Server running XP and Ubuntu inside VirtualBox.

BitTorrent on WinXP - doesn't upload

Transmission on Ubuntu - doesn't upload

I've flushed the firewall rules on the host machine and there is no firewall enabled on either the XP or Ubuntu VM. I'm not sure where to go from there.

Both VMs are using bridged networking with a static ip address, which I can ping and connect via RDP/NX without problems.

Any ideas?

EDIT: Tried rtorrent and it seems to be uploaded.. slowly.. but I guess that's normal for my crap connection. Better then not uploading at all. :P

Edited by Charles
Link to comment
Share on other sites

From the VMs can you ping your gateway or google.com at all.

If not try setting your VMs to obtain an ip address dynamically.

That's how my VMs are configured and I am also able to upload and download torrents without any issues.

Edited by Infiltrator
Link to comment
Share on other sites

The VM's are more or less behind an invisible router because VMware and such set the VM's up with NAT. Think of port forwarding in your router for games or other services, whats happening is in your home network, your router and your desktop work together and you port forward to an IP on the router that matches the machine needed that port open, like for bittorrents. Since the VM is sort of behind another router you cant see or control directly since its part of the VM software, its internet > modem > router > desktop > vmware/or vm software >vm running bittorrent.

If you set the adapter to bridge, then this should easy your troubles a bit and should get it working. If its set to NAT, then configure your VM to be on the same subnet as your local area network, and point to your router as the gateway and port forward on your router to the VM's IP Address for the port you need to upload in bittorrent and see if that works.

Link to comment
Share on other sites

I just checked my VM configuration and its set to NAT instead of bridge. I do not have any ports opened on my firewall, except for upnp. And I am able to upload. The VM is on the same network segment and it is set to obtain an ip address dynamically.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...