Jump to content

Bt4 Drops To Busybox After Editing Casper Script


Recommended Posts


I tried changing the location of the casper folder using the script by H@L0_F00 here: http://hak5.org/forums/index.php?showtopic=15600

Unfortunately, it looks like the path is correct, but all I get after booting off it is an error then drop to shell.

I don't know if my menu.lst entry is correct or not, since the path to casper is: /multipass/bt4-final/casper

title Start BackTrack FrameBuffer (1024x768)
kernel /multipass/BT4-final/vmlinuz BOOT=casper boot=casper nopersistent rw quiet vga=0x317
initrd /multipass/BT4-final/initrd.gz

Any help is appreciated since I want to have both BT4 Final and BT4 R1 on my multipass.


Edited by Charles
Link to comment
Share on other sites

Tried booting without the quiet option.

VFS: Cannot open root device "<NULL>" or unknown-block(8,1)

Please append a correct "root=" boot option; here are the partitions:

hda1 ide-ge

hdb1 ide-ge

hdc - cdrom

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)

Pid:1, comm: swapper Not tainted #1

There is no listing for the thumb drive.

I don't know if I screwed up something when I modified the scripts or what.

Edited by Charles
Link to comment
Share on other sites

Well, I messed with some of the kernel options and got it to error out at:

Warning: unable to open initial console.

Failed to execute /multipass/bt4final/initrd.gz. Attempting defaults.

Kernel Panic - not syncing: no init found. Try passing init= option to kernel.

EDIT: Same error occurs after recreating initrd*.gz and messing with the path.

Any ideas?

EDIT2: I replaced the new initrd800.gz with the original initrd800.gz (with casper at the root of the drive) and it booted fine.

Is there a reason that it's not able to load the new initrd.gz file?

Edited by Charles
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...