Jump to content

Jasager Seem To Not Be Working


Recommended Posts

Dear all

Just bought the Wifi Pineapple v2 from Hak5

Out of the boxs I connected to the battery pack included as I did not have and power adapter converter for USA to Europe.

I connected again the batterypack, hooked up an RJ45 cable and booted up my laptop with Backtrack 4

As indicated in the instructions the pineapple should be allready configured and setup with latest firmware..

I first went and did

ifup eh0

then

ping 192.168.1.1

RESULT: Nothing, cannot be reached.

I also tried

ping 192.168.1.1:1571

Nothing..

I am not sure what to do els, so I am relaying all my hope on a genius with in this forum to soulve my issues so that

I can use my long awaited Jasager

Ps.

Should there be any light on the Jasjager to indicate a power on feature?

NB

I am running BT4 on Broadcom b43 driver - works great with injection and capture ( wlan0)

Eth0 - not sure what it is or how to find out

Regards

exeption

Edited by exeption
Link to comment
Share on other sites

I can add the following as well:

Connect to the battery pack:

Cannot see any pineapple or myplace in wicd

Connected with a cable

wget 192.168.1.1

No network found

ifconfig eth0

eth0 Link encap:Ethernet HWaddr 00:c0:9f:b5:4f:fa

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:18 Base address:0xa000

PS..

Don't know how to find the config file either, there seem to be in BT4 nothing on

/etc/config/wireless

/etc/config/network

I have /etc/ but no config, wireless, network folder or files

Please help me

Link to comment
Share on other sites

ifup eh0

should be eth0, this is usually your wired interface. You need to set this to an IP address on the 192.168.1.0/24 subnet. I personally hate any of the automatic network start up scripts and GUIs so from the command line I'd do

ifconfig eth0 192.168.1.22 up

which will put your eth0 (wired) interface on 192.168.1.22. Do this and see if you can ping it then.

Depending on whether you got a Fon or an OpenMesh depends on what lights you get. Best plug it in to the power to guarantee it is working. A friend tried his OpenMesh on brand new batteries and got a light but it didn't work till he gave it mains. Different batteries fixed it.

Link to comment
Share on other sites

Thank you very much for answering my questions

1. ifconfig 192.168.1.22 up

ok

ifconfig

eth0 Link encap:Ethernet HWaddr 00:c0:9f:b5:4f:fa

inet addr:192.168.1.22 Bcast:192.168.1.255 Mask:255.255.255.0

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:18 Base address:0xa000

ping 192.168.1.22

root@bt:~# ping 192.168.1.22

PING 192.168.1.22 (192.168.1.22) 56(84) bytes of data.

64 bytes from 192.168.1.22: icmp_seq=1 ttl=64 time=0.052 ms

64 bytes from 192.168.1.22: icmp_seq=2 ttl=64 time=0.050 ms

64 bytes from 192.168.1.22: icmp_seq=3 ttl=64 time=0.054 ms

64 bytes from 192.168.1.22: icmp_seq=4 ttl=64 time=0.051 ms

64 bytes from 192.168.1.22: icmp_seq=5 ttl=64 time=0.049 ms

64 bytes from 192.168.1.22: icmp_seq=6 ttl=64 time=0.052 ms

64 bytes from 192.168.1.22: icmp_seq=7 ttl=64 time=0.050 ms

64 bytes from 192.168.1.22: icmp_seq=8 ttl=64 time=0.055 ms

64 bytes from 192.168.1.22: icmp_seq=9 ttl=64 time=0.053 ms

64 bytes from 192.168.1.22: icmp_seq=10 ttl=64 time=0.052 ms

^C

--- 192.168.1.22 ping statistics ---

10 packets transmitted, 10 received, 0% packet loss, time 8999ms

rtt min/avg/max/mdev = 0.049/0.051/0.055/0.009 ms

Works great...

For now it seems to be ok so far.. I leave this post on standby until I receive my US to Europe socket converter for my power adapter.

There is no aktive light on the Jasager when the battery pack is connected, the moves me to believe it is not working as you perdicted.

Depending on whether you got a Fon or an OpenMesh

This I am not sure about, just bought the Wifi Pineapple v2 from Hak5 store.. Darren told me that is was pre-configured out of the box ready to be used. with battery pack included.

Anyway, need now to wait a bit for the converter has arrived in my mailbox to test the Jasager on power supply.

Ill be sure to offer a free pint or two if ever ending up near Sheffield, Appreciate any assist related to getting this Jasager to run on my BT4.

Link to comment
Share on other sites

Just an update...

Jasager is now working with the new US/Europe adapter.

1. ifconfig eth0 192.168.1.1 up

ping 192.168.1.1 works great

Then, checked my wicd and finally there if was, listed on top with 88% "pineapple"

Ok, then I went to disconnect my personal AP and tried 192.168.1.1 on the brower ( Did not work)

Ok then I went to try the 192.168.1.1:1471 (Did not work)

Oh I thought, I need to connect to the pineapple wifi, and did of course

Ok, then i did a 192.168.1.1 in the browser and indeed there it was, the login page..

Ok logged into the menu, guess that was the Jasager menu..

Was not sure what to do here, but I changed the time zone to my home place

Then. I logged out and went on to loggin into the 192.168.1.1:1471 through the brower

And there it was, the Fon menu, base of operation..

Ok I thought, now I am up an running, just have to enable the karma and then sit and wait till someone logs on.....

After a while it got boring, either something is not working or I am doing this all wrong.

I went out and fetched my second laptop and did a power up to see if the Jasjager capture this laptop trying to log on the network.

Nope, did not

So I went to disconnect from my private AP and did a logon to "pineapple" by wifi, and sure enough, there is was listed under the client list.

Ok I thought to my self, so the meaning is that this Jasager operate just like a normal access point, an open way for others to connect to in order to get free Internett e.g.

But no i thought, as I did a browser open to my default page there was no Internett connection

Question? Is this because I have not pressed the execute option in the client list next to the connected laptop? Will the client get the Internett access from my 1 laptop through Jasager when executed?

I am not sure on how this work, that is not obvious right? LOL

The Jasager is now connected through an LAN cable to my first laptop which again is connected to my pineapple (thou when righting on this forum I had to be connected to my private ap in order to get Internett access).

I am looking at this all wrong or am I on the right track, perhaps there is a tutorial somewhere..

(Norwegian Vikings tend to be fast learners, just give them a weapon and see what happens ;) )

Link to comment
Share on other sites

Ok, seems to working I think..

When doing ifconfig eth0 192.168.1.22 up I can ping 192.168.1.1 and connect to the 1471 port

But, when I then try to connect my wireless to my private AP It seem to be disconnect somehow and I need to run ifconfig eth0 192.168.1.22 up once again.

I did see just before my self being added to the client list, but when I tried to press execute to add to the SSID list, then this message

was put in the log file.

class='warning'>There was a problem adding the SSID: no response text

So my question are once again.. Is it correct that I need to connect to my private AP when connected to eth0 with 192.168.1.22

Seem that I either can get the interface by connecting to the pineapple or though ethernet cable 192.168.1.1 when eth0 is set o 192.168.1.22

How does this work

1. First thing to do is to just be monitoring the Jasager via the eth0?

1. First thing to do is to connect to the pineapple with wlan0 and then monitoring?

How to connected clients get there Internett access as normal, is the Jasager just picking up everyone that tries to connect their own AP and show this as client connected in the client list? Why did it have issues with me connected to my own wireless ap ?

Please help me, I am dying to get this to work in an orderly fashion..

Regards

exeption

Link to comment
Share on other sites

I'm a bit confused by your questions but I think you want to set internet connection sharing up, check the forums for ICS.

I am sorry Digininja, I would deleted all the post just to make it more clear if I could.

Ok

The Jasager is running fine, no problem there and it is running 192.168.1.1

1. Pineapple v2 is connected to an laptop (HP ZE2000) with an LAN cable

2. Laptop has a Broadcom b43 wireless card with can do injection and internett connection

3. OS is Backtrack 4

When power is on and all lights are showing

1. 192.168.1.1 goes to openwrt interface

2. 192.168.1.1:1471 goes to FON gui - Here the status is up and karma is set to on

Now wicd shows that a wired connection is connected and pineapple is showing in the wifi list with 100%

Ok so far so good?

To confirm this working I went and fetched my Acer Aspire 7735ZG and connected to my neighbours open network AP, with his permission of course.

1. In the Fon Gui interface by 192.168.1.1:1471 the client mac is listed in the connected list

Ok so it works, but here is the problem

On the Acer now connected to the open network there is no active Internett, and this should be working

2. in Fon I executed the client SSID to the whitelist

3. I went back to the Acer and there it was, I was able to surf the internett.

Ok, to see if I got this right, You need to whitelist every client that connects????

The connected Jasager need to share my wlan0 connection right, did I understand that correctly?

Edited by exeption
Link to comment
Share on other sites

White and black listing is broken in the firmware so adding things to the list won't actually do anything. Just make sure that it is set to blacklist and it will work fine.

What have you done to setup connection sharing between the device and the laptop?

Link to comment
Share on other sites

White and black listing is broken in the firmware so adding things to the list won't actually do anything. Just make sure that it is set to blacklist and it will work fine.

What have you done to setup connection sharing between the device and the laptop?

Nothing really digininja, I will now read your suggestion thread about ICS and take it from there.

1. Jasager is now put to blacklist..

Link to comment
Share on other sites

Ok then back to work..

Have now read several articles on DHCP, ICS and bridging and so far I have some ideas and questions

1. The US version of the Jasager has only i WAN port - This mean that is a La Fonera 2100 right and not the La Fonera+ UK version with 1 WAN and 1 LAN port ???

So, basically when connecting a CAT5 cable from the LAN port on my laptop to the WAN port of the FON will not be working without any form of options to modify the WAN port into a LAN port right?

My thoughts so far is this:

Am I totally wrong when I think that in order to get this damn thing to work with my laptop I need to do the following things:

1. The laptop needs to be running DHCP or a virtual hub

Example

sudo brctl addbr vhub #This creates the virtual hub

sudo brctl addif vhub eth0 #This connects eth0 to the virtual hub

sudo brctl addif vhub wlan0 #This connects wlan0 to the virtual hub

sudo ifconfig vhub up

2. I can use a dhcp client on my laptop so that all clients connected to the Jasager will get their IP and Internett connection from the DHCP IP pool set on my laptop that runs Wlan0 and connection to my Netgear AP

So two ways to solve this issue right? Either way, The Jasager out of the box wil never be plug and play, is that the correct assumption?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...