Jump to content

Dhcp And Webif.


Recommended Posts

dhcp and bridging are two different things. To disable the bridge you just modify /etc/config/network and change the line that mentions bridge.

For DHCP I can't remember off hand how it is started, I think I'm wrong here but have a look in /etc/init.d for a script that mentions dhcp and remove it if it exists.

I haven't got a fon to hand to check.

Link to comment
Share on other sites

ok thanx :)

Will have a look and see but won't touch unless I'm sure what I am editing. More interested in starting DHCP than disabling bridge at the moment....still at war with this fon+ and the "half internet syndrome" but managed to make a little progress yesterday. ;)

I can see why linux rules in this area and should really make more effort in using it for more applications than I do.I have had real success using ubuntu and the aircrack suite of tools where it's performance is excellent.

B)

Link to comment
Share on other sites

:)

Had alook in /etc/config/network using vi cmd and under the section config 'interface' 'lan' I see........

option 'type' 'bridge'

option 'proto' 'static'

option 'netmask' '255.255.255.0'

option 'ifname' 'eth0.0'

option 'ipaddr' '192.168.0.2'

option 'gateway' '192.168.0.1'

option 'dns' '192.168.0.1'

Can I not just edit the 'static' in line 2 to 'dhcp' using vi text editor and enable dhcp on the fon that way?

@ digininja I can not find a file /etc/init.d------Get this error form vi /etc/init.d .... "etc/init.d" Not a regular file.

I am most likely doing something wrong there but my linux is not that good. :rolleyes:

Link to comment
Share on other sites

Thought you were talking about dhcp server. Ye, just comment out the other lines and change static to dhcp. This makes the device get its IP from a dhcp server. Only do this if you are definitely running a dhcp server on the network that the Fon can see. If you don't have a dhcp server running then it won't get an address and you won't be able to get back in to it until you set one up.

init.d is a directory with files in it. I was meaning look in there for one that talked about dhcp when I thought you were talking about setting up a server.

Link to comment
Share on other sites

So what are the advantages of setting the lan configuration connection type on the fon to dhcp and is this really necessary? My grounds for this question are if I set lan config to 'dhcp' the fon gets assigned an IP from the dhcp server.....this IP is always on the wrong subnet 1.xxx (coming from my home router) where as my subnet for ICS is on 0.xxx. (as it has to be)

Am I getting mixed up here with running a dhcp server on the fon and simply setting the lan type to dhcp.....are they seperate things? :unsure:

I know I ask a lot of questions but I am determined to find out why this fon is accessing the net only partially through ICS. :P

Link to comment
Share on other sites

There are two distinct things, a dhcp server and a dhcp client. The machine running the dhcp server can't also be a dhcp client (Technically it can but I'm not going to go there) so you have to either have a static IP on your Fon and have it as your ONLY dhcp server or you can use the dhcp server on your router and then either use dhcp or static IP for the Fon.

The advantage of running the dhcp server on the Fon is that it means Jasager can detect the IP addresses being given out, without it it is only really bridging traffic

Link to comment
Share on other sites

Thanx for the quick reply digininja :)

My home router is set as dhcp server. So having my fon set at static IP keeps my subnet aligned nicely and would make no difference in connection apart from jasager not being able to see the IP's that are given out.....therefore dhcp is not my problem with connected clients only getting partial internet through the fon. If I were to set up dhcp server on the fon and at the same time run dhcp server on my home router there would be a big bang so to speak?

Just trying to establish how things work a little more clearly and hopefully get to the bottom of this. :blink:

Link to comment
Share on other sites

Static IP on fon is set to 192.168.0.2 I was only going to run the dhcp server on my home router (AP) as I thought this would make it more realistic if I were testing this elsewhere and had no way of configuring the AP.

It is quite annoying this little problem as the fon is obviously granting some internet access to connected clients. Google works ok,pictures maps,images etc and some websites will connect...some straight away....some slowly load and others not at all. If I plug my other pc into the ICS laptop ethernet nic,that the fon usually goes into,the connection shares 100% no problems indicating that the problem lies on the fon.

I have done an ipconfig /all ,on the pc that shares 100% no problems through my ICS laptop,and replicated the settings for dns on the fon.....still the same problem.

:rolleyes:

connected clients can also ping successfully google.com,4.2.2.2 and 8.8.8.8. Try doing that from the fon and there is no response.

Edited by kendalkake
Link to comment
Share on other sites

You are saying that some sites work and others don't, then it isn't a networking issue, IP and routing must be working OK for you to get to some sites. Debugging this is different to what you've been talking about so far.

To track this down you need to install some kind of packet trace on the ICS machine and on the Fon and watch where the packets go, see where they are dropped. I'd suggest tcpdump on the fon, no idea on windows.

If you don't know how to use these apps then learn them on a basic setup first then come back to debugging this setup.

Link to comment
Share on other sites

Afternoon :)

Tcp dump I have on ubuntu but have never really experimented with it apart from viewing the capture file from it with wireshark. Looks like I have some more reasearch to do then!

Thanks digininja at least I know the IP and DNS set up is ok....Just need to know where I am dropping packets then.

My money is on the fon....but who knows??? :rolleyes:

Link to comment
Share on other sites

:D Got it!!!!!

At long last clients connected to the fon can now enjoy full internet connection :)

Everything works fine although I might move the static IP of the fon up the subnet a little.

QUOTE:Just need to know where I am dropping packets then. My money is on the fon....but who knows???

WRONG! :o The fon was fine....no problem with it at all!! I can now see connected client macs and assigned IP's in the jasager interface. Internet working 100% ...no problems. :)

How? Today I sat quietly eating pineapple,well actually it was a bacon buttie lol, and had a think about what digininja said about dropping packets. OK so out went the rule book...I pieced together an idea from parts of others and gave windows the boot. Off to ubuntu I went with my crude idea and set to work setting up ICS there instead....well what do you know? 10 minutes later connection up and running 100% :D I can't answer why ICS would not work for me in windows and I will probably never know as many others have succeeded where I have failed.I had tried ICS in ubuntu before and failed but now realise my fon was configured incorrectly and therefore that was the reason why.

Thank you for your patience and help digininja.....You got me there in the end lol. B)

time to move forward....phew!! :rolleyes:

Edited by kendalkake
Link to comment
Share on other sites

:lol: pmsl @ digininja.

I am not a total stranger to linux but only have a very basic idea when using it and frequently get things wrong as you have seen...lol.

A while back I was experimenting with a program called commview for wifi on windows and what a waste of time that was. I soon learned that linux and a different set of tools worked much better and my success rate was massive,that was my first encounter with ubuntu.

This problem with windows ICS has been an eye opener but also it has been fun along the way by learning a bit more about linux, having a peek around inside the fon and learning to edit files instead of using the webif gui.

linux is getting the thumbs up from me! :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...