Jump to content

couple of points?


Recommended Posts

:) Good afternoon!

I have found conflicting instructions for setting up the fon+ with ICS in win xp can somebody please clear a couple of points for me.

1. Most guides say set the fon to DHCP with a bridged connection and IP of 192.168.0.250 using webif gui.....I have also read to give the fon a static IP and not DHCP with a bridged connection......Which one is correct?

2.quote: "You need to connect to the fon and on the OpenWRT gui change the fon router to have a DHCP & Bridged connection and put in the ip address 192.168.0.250"....? Ok my lan the fon is on has to be set to 192.168.0.1 (windows does this when setting ICS up and it can not be changed)

Quote: And running a dhcp range of .1 to .250 is a bad idea, it only leaves you 4 static IPs to work with which limits what else you can have on the same subnet running on fixed IPs.

so how can I avoid that range of 192.168.01 - 192.168.0.250?

much obliged to anyone who can help. :)

Link to comment
Share on other sites

the instructions HERE work perfectly for windows machines I have successfuly set the fon up using these instructions and implemented Hamster and Ferret to sidejack any connections that come thru. follow these instructions and if you get stuck somewhere I can help you along :) Happy hacking

Link to comment
Share on other sites

Cheers :) .....just one point I may have misunderstood in there,although I have been here before and it failed.

Quote: The point is, you want to plug in those DNS server settings from the ICS enabeld NIC into the IP properties of the other NIC, and save the configuration.

Do I put those in:

IP address: xxx.xxx.xxx.xxx or preferred dns server: xxx.xxx.xxx.xxx

on the other nic?

my 2 previous questions are still open to answers. :D

Link to comment
Share on other sites

You only need to use the DNS settings from the other NIC the IP adress is set to 192.168.0.1 by default by windows to act as the server for ICS so just use the DNS address or addresses if you have two.

The Ip of the Fon is set on the fon either SSH or the webif if you want is easiest for most and must be set to 192.168.0.x where X is any number 2-254 it doesnt have to be 250 like you said in previous post but you do need to remember it cause it will be the IP you access the fon with whether it be SSH or just accessing the web interfaces.

So your NIC's ip is 192.168.0.1 -- assigned by windows

and your FON's ip is 192.168.0.x -- assigned by fon settings

hope this has cleared things up for you I think I covered everything you wanted to know let us know how things work out for you. share your thoughts and ideas as you progress :D

Link to comment
Share on other sites

Thank you for the reply :)

That makes sense! This is how I am configured from AP back to fon....digininja has pointed out a fault with it and I respect his answer and no doubt he is right . I am misunderstanding somewhere.....Take a look.

home router settings (my AP for the internet)

IP: 192.168.1.1

Sub mask:255.255.255.0

(router set as DHCP on)

ICS laptop (configured ok)

Ethernet nic (fon connected to) IP: 192 168.0.1 (automatically set by windows in ICS set up, can not be changed)

Preferred dns server: 192.168.1.1 (taken from ipconfig /all on my ICS nic)

FON+ settings (wireless has been enabled with commands)

uci set network.lan.ipaddr= 192.168.0.2

uci set network.lan.gateway= 192.168.0.1

uci set network.lan.dns= 192.168.1.1

uci commit network

Then in /etc/config/dhcp...under the section config dhcp lan using vi editor I have added:

list 'dhcp_option' '3,192.168.0.1'

list 'dhcp_option' '6,192.168.1.1'

Saved and exited using ZZ command.

digininja's reply Quote:

The problem is still that your gateway is on a different subnet to the rest of your network. You'll need to put that on the same network.

.......................................................................

This is what I can not grasp but am obviously doing wrong....here is why I don't understand.

If I change my lan gateway from 192.168.0.1 to 192.168.1.1

The fon will not connect to my ICS laptop as the nic it is connected to on that laptop is automatically configured to 192.168.0.1 by windows and it can not be changed.

If I manually change the nic on my ICS laptop to 192.168.1.1 then I get an IP conflict on the system?????

Where is my error??? I just can't see it....throw eggs if you like....lol :D

All my clients connected to the fon can only browse google.

Link to comment
Share on other sites

Thank you for the reply :)

That makes sense! This is how I am configured from AP back to fon....digininja has pointed out a fault with it and I respect his answer and no doubt he is right . I am misunderstanding somewhere.....Take a look.

home router settings (my AP for the internet)

IP: 192.168.1.1

Sub mask:255.255.255.0

(router set as DHCP on)

ICS laptop (configured ok)

Ethernet nic (fon connected to) IP: 192 168.0.1 (automatically set by windows in ICS set up, can not be changed)

Preferred dns server: 192.168.1.1 (taken from ipconfig /all on my ICS nic)

FON+ settings (wireless has been enabled with commands)

uci set network.lan.ipaddr= 192.168.0.2

uci set network.lan.gateway= 192.168.0.1

uci set network.lan.dns= 192.168.1.1

uci commit network

Then in /etc/config/dhcp...under the section config dhcp lan using vi editor I have added:

list 'dhcp_option' '3,192.168.0.1'

list 'dhcp_option' '6,192.168.1.1'

Saved and exited using ZZ command.

digininja's reply Quote:

The problem is still that your gateway is on a different subnet to the rest of your network. You'll need to put that on the same network.

.......................................................................

This is what I can not grasp but am obviously doing wrong....here is why I don't understand.

If I change my lan gateway from 192.168.0.1 to 192.168.1.1

The fon will not connect to my ICS laptop as the nic it is connected to on that laptop is automatically configured to 192.168.0.1 by windows and it can not be changed.

If I manually change the nic on my ICS laptop to 192.168.1.1 then I get an IP conflict on the system?????

Where is my error??? I just can't see it....throw eggs if you like....lol :D

All my clients connected to the fon can only browse google.

Link to comment
Share on other sites

change your router to have a different ip address such as 192.168.0.2 or if your using it make it something else like 192.168.0.199

this allows the ICS server ( 192.168.0.1 ) to be a client of your network assigned by your router ip address 192.168.0.X where X is any number that is not taken obviously since the nic leading to the fon has to be 192.168.0.1 then you must work around it by assigning your computer and the router different ips other than .1 the new DNS setting will be needed from the steps above as your routers is your DNS server so it will change to your newly configured address

using static ip address settings on your router will be very useful for making sure your computer doesnt take the address 192.168.0.1 before the ICS'ed adapter takes it

Link to comment
Share on other sites

hmmmmmmm!

ok .......so what would I do if,lets say I was out in the field somewhere and was using a free access point for my web connection and had no way of configuring it but that free access point was using 192.168.1.1 as most do....?

Is this why windows serves up that Ip of 192.168.0.1 automatically? (can linux do different?) I wonder????

I get what you are saying now....correct me if I'm wrong.

Because my fon is on 192.168.0.2...everything that follows after the fon must use the 192.168.0. xxx subnet.

be it 192.168.0.199 or 192.168.0.5 or whatever on 192.168.0.xxx so long as it is not 192.168.0.1 (ethernet nic ip) or 192.168.0.2 (fons ip addy)?

Have I got it right now?

Thanx for you help and patience :D

Link to comment
Share on other sites

My mistake it does not need to be configured in the same subnet

Windows should share the connection either way make sure you connect to the network providing internet first without the fon connected then enable ICS then update the DNS according to the router you are connected to the connect the cord to the fon whose ip should be 192.168.0.X besides 192.168.0.1

Link to comment
Share on other sites

I did that...ticked all the boxes when I set up ICS and clicked ok. Still connected clients can only view google. But if I plug my other pc into the ethernet nic instead of the fon on my ICS machine the connection shares 100% no problems???? strange don't you think?

Link to comment
Share on other sites

yeah strange but that means its settings on your fon

Are you being assigned an ip address when you connect wirelessly to the fon? check windows settings

is it reporting the accurate DNS server

also check OpenWRT for logs Syslog and Firewall log also check the status log while connecting to the fon wirelessly to see if there are any errors ill try to trouble shoot this problem for you ill see what else i can come up with

It is possible that google is saved on your computer and when you open Firefox or IE it is only pulling the page up from your hard drive not actually accessing the internet thats why we havn't eliminated a ip conflict or DNS error yet

Also make sure your network configuration in OpenWRT is set to DCHP Bridged

Link to comment
Share on other sites

FON+ settings (wireless has been enabled with commands)

uci set network.lan.ipaddr= 192.168.0.2

uci set network.lan.gateway= 192.168.0.1

uci set network.lan.dns= 192.168.1.1

uci commit network

Your DNS server should be your gateway address 192.168.0.1 reset it and recommit the settings this looks to be the problem digi was talking about I believe

Sorry I shoulda read your post more carefully as the wise Digininja had already provided the answer you were just going about it the wrong way

Link to comment
Share on other sites

  • 2 weeks later...

Hi m8 :) Only just got back on to the forum after some persistence due to the technical difficulties.

Thank you for your help B)

ok so my lan dns is wrong! I will reset and recommit the settings tomorrow and see what happens. I hope you are right as it looks like I could not see the wood for the trees.....lol

Glad the forum is back up and running and my thanx to those involved with the repairs. :D

Link to comment
Share on other sites

Going round in circles with this....lol Reconfigured the fon's lan dns to 192.168.0.1 and adjusted accordingly in /etc/config/dhcp.

still the same!!! connected clients can search with google but nothing else will load. It's as if windows knows what the fon is doing and stopping it in it's tracks..... :(

Digininja suggested putting the fon on the same subnet as my home router but this is impossible as ICS assigns an IP to the nic of 192. 168 .0.1 and if this is altered ICS shuts down!

Ubuntu 9.04 is even worse and allows no access at all.....I am beggining to think the fon may be fooked! :o

webif seems almost useless as when I use it to set DHCP on the fon it assigns a new IP to it and although I know what this IP is I can not gain access to the fon with this IP through putty and the fon is "jammed" with this new IP which is also preventing connection through ICS.

I am going to have to re flash again as the fon has now locked itself up!!

Link to comment
Share on other sites

Heya good to see your back sorry to hear your still having troubles

to access your fon you shouldnt have to re flash If you plug it into your router ( since its a DHCP server ) it should assign an ip to the fon then you can access the routers interface and see what ip was assigned then log in thru that ip.

We sure seem to be having alot of trouble getting it to work for you Im reflashing tonight or tommorow and then I will be able to help you again Im thinking maybe a router setting needs to be set to allow traffic from the other subnet to be able to access the wan side of your router thus the internet but let me reflash and we will go thru your network settings again

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...