Jump to content

Problem with NAT


etftw
 Share

Recommended Posts

Hey,

Well kind of out of the blue I have been having some issues with my NAT setup, I have recently started gaming again via Xbox LIVE and noticed it was stating my NAT type is not classed as open, which I found odd as I had enabled uPNP not long ago, so I went into my router configuration and uPNP was still enabled but seeing as that wasn't working I forwarded the ports, unfortunately there was still no luck. I even went as far as to put the Xbox into the DMZ however the NAT type was still classed as strict.

I have done these tests with my PC as well using the uTorrent port checker which used to connect to the ports I specify with no issues, however now it always fails regardless of whether my PC is in the DMZ, has the correct port forwarded etc.

In addition to this I should probably mention that I have tried hooking straight up to my modem at which point there are no issues, so it is definitely not a case of my ISP blocking the ports.

Does anyone have any recommendations as to what may be the problem? I have been trying to solve this one for hours and I have come to a dead end, hopefully there is a networking guru out there who can save me from throwing it out of the window!

Cheers.

Link to comment
Share on other sites

Turn off uPnp and then set up the router for a DMZ on the 1 address assigned to the game console only, see if that works.

Link to comment
Share on other sites

just to verify did you forward on these ports and protocols?

TCP 80

UDP 88

UDP 3074

TCP 3074

UDP 53

TCP 53

Yup, I have all of those ports forwarded using the appropriate protocols.

Turn off uPnp and then set up the router for a DMZ on the 1 address assigned to the game console only, see if that works.

Unfortunately I am still getting the problem after following this process, I will try to restore the router to factory settings and start fresh using this order and see if it works after that.

Link to comment
Share on other sites

I have an update - I restored the router's factory settings, disabled uPNP and then put the Xbox into the DMZ and now it is not detecting any NAT problems, I tried forwarding the ports when it wasn't in the DMZ again but they still resulted in a NAT error.

So I have an additional question that goes a bit off topic from the original purpose of this thread, which is: how safe is it to leave the Xbox in the DMZ? I imagine as the Xbox is not capable of much in terms of access to the rest of my networked machines and the execution of malicious software it shouldn't hold much of a threat to the security of my network, but if I am wrong please someone point it out so I can look for an alternative solution :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...