Jump to content

SSH - ls not working


Recommended Posts

Just flashed fon with jasager firmware and when do ls in the telnet it works. i passwd and reboot, login to ssh and it will not let me ls. Does not show any files or directories. WinSCP see's all the files though.

ifconfig show me my br-lan, eth0, lo

cd doesn't work, ls doesnt work.

any clue as to what i need to do to fix plz?

Link to comment
Share on other sites

What happens when you run ls or cd?

When I run ls it doesn't list any directories after I passwd in telnet. Just gives me a root@xxx prompt to give another command.

When I run cd it said something like it could not change to the directory.

This site briefly talks about an issue. I guess they think it's something with not mounting properly.

http://www.myopenrouter.com/forum/thread/1...ing-in-OpenWRT/

I tried reflashing with openWrt 7.09 files, the firmware again. Same issue. Telnet works... SSH does not show anything for those 2 commands. But ifconfig shows the adaptors... very odd.

According to that link's list of mounted items:

rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw)
/dev/mtdblock/4 on /jffs type jffs2 (rw)
mini_fo:/jffs on / type mini_fo (rw)

This is what i get when i type mount:

rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,size=6884k)
tmpfs on /dev type tmpfs (rw,size=512k)
devpts on /dev/pts type devpts (rw,mode=600)
/dev/mtdblock2 on /jffs type jffs2 (rw)
mini_fo:/jffs on / type mini_fo (rw)

not sure it that helps at all. Going to try the gargoyle flash now.

--Edit: Nope flashing with your firmwre with gargoyle didnt work either... same symptoms.. wtf :|

WinSCP sees all the files, but there was an error it had saying pwd returned an error. I'm going to just delete all files i can, reflash, and hope for the best...

--Edit: WinSCP cannot delete any files due to return code 1 and error message. Invalid Argument. Or file is Read Only. Also i see a lot of -ash: rm: not found

Cannot change directories in WinSCP too. It's like it doesnt know what the commands are...

Should i start making my serial cable?

http://www.dd-wrt.com/wiki/index.php/LaFon...console_adapter

Got all the parts already.

Link to comment
Share on other sites

Ok, apparently I was tired and way over analyzing this. I was by default in the /root folder which doesn't have a var directory or tmp. I did a cd / and went to the root of the drive. What a shock my folders and files exist. Sorry for confusing the hell out of everyone. Sometimes basics get forgotten lol.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...