Jump to content

Ubuntu 9.04 Persistent


Netshroud
 Share

Recommended Posts

I've come across a wierd bug, anyone know what's wrong?

Ubuntu 9.04 Live boots fine from ISO.

Ubuntu 9.04 Persistent drops to a BusyBox shell.

The only difference is the word "persistent" in the kernel line.

I have a cleanly made casper-rw in the root of my USB.

I'll try modify the initrd scripts later.

Link to comment
Share on other sites

Maybe the casper file(s) has to be in a folder named "casper" on your root like with BT4 without editing your init scripts? And just so you know, I don't think it's the init script itself that finds and mounts the casper file system, init calls a bunch of other scripts. I plan on working on figuring out how to move around the casper folder though which shouldn't be too hard or time consuming since I've messed with Ophcrack successfully.

Link to comment
Share on other sites

So casper-rw also has to be contiguous? Thanks, running contig now, will test when its done.

Without modifying init scripts, casper-rw has to be in the root.

I think he/she/it means that if there is any error in the file system of casper-rw it won't boot. Like maybe you didn't specify a command while making it, assuming you made it.

Link to comment
Share on other sites

So casper-rw also has to be contiguous?
The contiguous part was a guess :P

Well I ran contig, and it defragged the file from 51 frags to 1, and it worked. It doesn't work on my school computers though, I'll see what I can do here.
Does Ubuntu even correctly boot on your "school" computers without persistent mode enabled?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...