Jump to content

Fon+ Strange AP names


Recommended Posts

Hey all,

I installed Jasager on my newly purchased fon+ following Chris Oliver's blog post (http://excid3.betaserver.org/fon-2201/openwrt-and-jasager-on-the-fon-plus/) and everything seemed to work superly. So I fired up Karma to test on XP (on a macbook pro under bootcamp) and I get the strangest Access Point names (see attachment). Anyone have any idea why this is happening? I haven't been able to test on another XP box because I can't find one (everyone in college loves OS X). This also leads me to my 2nd question, does Karma work with the remembered access points under OS X? From my tests it seems not to at all. Any insight into any of this would be appreciated.

Thanks,

-Pat

EDIT

Also very strangely when I connect to the OpenWrt access point to login to Jasager ipconfig shows that I have connected and have an IP but the windows "choose your wireless connection" does show me connected nor does it in the taskbar. Intresting...

post-12794-1233628171_thumb.jpg

Link to comment
Share on other sites

This has been asked before, have a read through there is an explanation of what is happening

Thanks for the response, I just took a read through the forums as well as a search and I couldn't find the post you were talking about except possibly this one. (http://hak5.org/forums/index.php?showtopic=11346&hl=access+point) but even that doesn't seem to have the same problem that I am having. I've reflashed twice with the same result. The only possible thing that went wrong during install was during the "ipkg install jasager-madwifi_1.ipk" The fon was not connected to the internet so I couldn't download

"http://downloads.x-wrt.org/xwrt/kamikaze/7.09/atheros-2.6/packages/./kernel_2.6.21.5-atheros-1_mips.ipk"

or

"http://downloads.x-wrt.org/xwrt/kamikaze/7.09/atheros-2.6/packages/./wireless-tools_29-1_mips.ipk"

But it said the install was successful, hmm..

Link to comment
Share on other sites

The fon shouldn't be beaconing any SSIDs, all it does is say yes when a probe request comes in. If your windows client is trying to be clever and looking at probe requests/responses as well as beacons that could explain it. I don't run windows and haven't see it the odd times that I have used a windows client so I can't help.

It is one of those problems that just shouldn't happen because of the way things are built.

I'll have a flick through the threads and see if I can spot the other person asking about it.

Link to comment
Share on other sites

I had the same problem with the funny AP names (and tons of them, every time i refreshed the list there were more and more). I think that it is caused by having an improper UCI configuration.

Hmm... any idea how to fix the UCI config... I'm trying to get jasager to work for a school project / demo? excid3 if you are Chris Oliver then I followed your tutorial on how to install jasager on the fon+ and you just recently helped me in a comment I posted on your site. Any help at all would be greatly appreciated.

Thanks,

Pat

Link to comment
Share on other sites

Hmm... any idea how to fix the UCI config... I'm trying to get jasager to work for a school project / demo? excid3 if you are Chris Oliver then I followed your tutorial on how to install jasager on the fon+ and you just recently helped me in a comment I posted on your site. Any help at all would be greatly appreciated.

Thanks,

Pat

Yep, im Chris. Same guy who wrote the tutorial.

What the uci commands do is set the configuration for your device. The one for your wireless configuration is usually stored in "/etc/config/wireless" so you can open that up and read through the configuration and see what is wrong. If you need help with it, post it here and we can take a look and get it fixed up for you.

Link to comment
Share on other sites

ok so here is my /etc/config/wireless file....

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'channel' '11'

config 'wifi-iface' 'cfg2'
        option 'device' 'wifi0'
        option 'mode' 'ap'
        option 'network' 'lan'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'none'

Link to comment
Share on other sites

Excellent thanks, I look forward to hearing from you.

Crap, I forgot I reflashed the Fon+ back to the original firmware. I found a tool to unlock the original firmware and was planning on using it to enable SSH. It will have the same sort of UCI config because its all based on OpenWrt, so once I get it unlocked I will get you my config. Maybe someone else could post their config as well?

Link to comment
Share on other sites

  • 1 month later...
ok so here is my /etc/config/wireless file....

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'channel' '11'

config 'wifi-iface' 'cfg2'
        option 'device' 'wifi0'
        option 'mode' 'ap'
        option 'network' 'lan'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'none'

Did you ever get this working? I am having the same problem. did you try to remove the line: option 'ssid' 'OpenWrt'

Link to comment
Share on other sites

I'm having the same problem (still) and haven't found a fix yet.

I'm actually thinking about starting from scratch (again), but to be honest I don't think that's going to accomplish much.

Link to comment
Share on other sites

I'll just mention again that Jasager doesn't send out any beacons so anything odd that your windows ssid list is showing is a result of it trying to interpret ssids information it is seeing in the air rather than taking the info from beacons as it is supposed to.

What wireless cards are you both using? Maybe there is some commonality on the card or driver.

Link to comment
Share on other sites

here is a pic of my jasager page...

Jasager status page

here is a pic of my webif wireless configuration page...

Webif Wireless Config page

just a note here, when i change the Essid on the webif page to something else (i.e. testap) i then find an OpenWrt and testap ssid in the network list. I then go back into the jasager status page and it looks like karma is working since after changing the ssid name it forced my nic to disconnect and reconnect and when reconnecting, it connected to OpenWrt which now does not exist :)

hope this helps other folks

Link to comment
Share on other sites

here is a pic of my jasager page...

Jasager status page

here is a pic of my webif wireless configuration page...

Webif Wireless Config page

just a note here, when i change the Essid on the webif page to something else (i.e. testap) i then find an OpenWrt and testap ssid in the network list. I then go back into the jasager status page and it looks like karma is working since after changing the ssid name it forced my nic to disconnect and reconnect and when reconnecting, it connected to OpenWrt which now does not exist :)

hope this helps other folks

Ok, just had a thought, I never set an ssid on the AP when running karma, I always leave it blank. Try that, see if that helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...