Jump to content

Vista autorun


p1rat33r
 Share

Recommended Posts

The payload seems to not self start on Windows Vista pc's. Anyone have a workaround?

Which payload? PocketKnife self-starts for me.

I put a picture on it, told Vista to auto-run all picture CDs, and boom, it auto-runs just fine.

Before that, it would simply ask me what to do with the removable disk, and if I clicked "open folder," it would also auto-run.

Link to comment
Share on other sites

I verified the same on my friends Vista (I don't have Vista myself) It does not autorun, instead it popup's for the cd-rom partition if you want to run it. And for the USB partition it pops up asking if you wan to open the folder to view the files... I tested with a Sandisk Cruzer Micro U3 drive. So maybe CD-Autorun is off by default in vista? I should try just a CD to see if maybe Vista can tell the difference between a real CD-ROM and the emulated CD-ROM? Anyway it probably can be changed with a registry key! but you'd have to do it before inserting your drive. Maybe run regmon by sysinternals and see what registry key(s) are changed when you change the setting to allow cd's to autorun. (if there is even such a setting)

@Verye: what do you mean by "picture CDs"? Do you mean ones that have an icon?

Link to comment
Share on other sites

He means by assigning the role of that CD as storing pictures so by default certain environment variables are set, Depends on the file types ofc. (Music,Pictures,etc) So by placing images on a CD and loading it Vista will ask what you want to do with that PICTURE.

Link to comment
Share on other sites

Don't know what to tell you guys. It would auto-run if I clicked "open folder," and after a data slurp put a picture on it, it asked me how it wanted to handle pictures on CDs (though, this applies to any removable disk) from now on. I said to have it auto-open them, and it does.

It's possible that the open folder/auto-open picture thing has nothing to do with auto-running, and auto-running is just, for some reason, enabled my default on my computer. I really don't know, sorry. :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...