Mr. #

Internet won't work on browser via LAN TURTLE.

10 posts in this topic

Recently got the turtle, configured it to the cloud server. I have Auto ssh enabled, but when connected to an ethernet, there is no internet connection to the computer. What could be the problem?

0

Share this post


Link to post
Share on other sites

Hi @Mr. #,

could you provide us some more information? With "computer" you mean the computer to which the LanTurtle is connected, right? not the LanTurtle itself?

Can you connect to the LanTurtle from another computer on the network via SSH? What OS is your computer running?

Does the LanTurtle show up as a device in your network connection?

0

Share this post


Link to post
Share on other sites

The computer to which the LAN TURTLE is connected to, yes not the LAN TURTLE.

I am running linux, and i am able to SSH into the turtle from another computer on the lan. However, the computer to which the TURTLE is connected to has no internet connectivity. With the turtle connected via ethernet to the computer USB.

i have attached a link of an image, failed to add one here.

 

http://www.filehosting.org/file/details/648635/today.png

0

Share this post


Link to post
Share on other sites

Hi @Mr. #,

could post the output of ifconfig? I'm not opening your screenshot as I would have to enter an email address...

0

Share this post


Link to post
Share on other sites

@Mr. #

  1. can you ssh into the lan turtle from the victim computer?
  2. could you please as I asked before post the output of ifconfig of your victim computer?
0

Share this post


Link to post
Share on other sites

@Mr. #
Do you happen to have Responder/QuickCreds enabled? If so, try disabling them/reboot the turtle and let us know the results.

0

Share this post


Link to post
Share on other sites

Doesn't seem like anyone has come up with a solution yet.


I will say that on both my Macbook and my Ubuntu desktop machine, if I plug the Turtle in, my browser will not connect to the internet. However, if I restart the machine once the Turtle is connected, the browsers will connect afterwards. Chrome always throws a DNS error and I think Firefox did as well. Why would a reboot fix it but spontaneous plugging in renders the internet browsing useless? This could be troublesome for deployment.

0

Share this post


Link to post
Share on other sites

Hi, dwagner, I'm probably late, but the problem you are facing is most likely related to the fact that dnsmasq is not told by default to use any external dns servers.

You can force it to use google's just by adding these 2 lines to the end of the /etc/dnsmasq.conf:

server=8.8.8.8
server=8.8.4.4

resolv.conf by default is set to 127.0.0.1, meaning that all name resolutions will be handled by the dns server located at 127.0.0.1, which is your instance of dnsmaq. Dnsmasq in turn, with these 2 lines, is told to forward dns queries to those external dns servers.

This may be still not be an ideal setup (probably if you also need to resolve local domain names successfully), but it currently suits my needs.

Just for the record, I have my laptop with wifi turned off, internet fed exclusively by an ethernet cable coming from the router, I disconnect the ethernet (I run out of internet), connect the turtle with default network settings, and connect the ethernet cable into the turtle. After 10 seconds or so, I can browse the internet as usual, and all traffic is coming to/from the turtle, even dns queries.

You can even see that the dns server for my adapter was indeed set to turtle's:

Ethernet adapter LAN Turtle:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek USB FE Family Controller #2
   Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fd8f:cf7a:45fa::2b1(Preferred)
   Lease Obtained. . . . . . . . . . : Wednesday, June 21, 2017 1:31:25 AM
   Lease Expires . . . . . . . . . . : Thursday, June 22, 2017 1:31:25 AM
   IPv6 Address. . . . . . . . . . . : fd8f:cf7a:45fa:0:80e2:f131:6eab:1fc6(Preferred)
   Temporary IPv6 Address. . . . . . : fd8f:cf7a:45fa:0:5066:45c6:2e58:f2f0(Preferred)
   Link-local IPv6 Address . . . . . : fe80::80e2:f131:6eab:1fc6%138(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.16.84.117(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, June 21, 2017 1:31:30 AM
   Lease Expires . . . . . . . . . . : Wednesday, June 21, 2017 1:32:21 PM
   Default Gateway . . . . . . . . . : 172.16.84.1
   DHCP Server . . . . . . . . . . . : 172.16.84.1
   DHCPv6 IAID . . . . . . . . . . . : -1979654068
   DHCPv6 Client DUID. . . . . . . . : XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX
   DNS Servers . . . . . . . . . . . : fd8f:cf7a:45fa::1
                                       172.16.84.1
   NetBIOS over Tcpip. . . . . . . . : Enabled
   Connection-specific DNS Suffix Search List :
                                       home

And turtle in turn redirects every query to 8.8.8.8, falling back to 8.8.4.4 in case 8.8.8.8 becomes unreachable.

Hope it helps.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.