Jump to content

C2 Server hangs

Go to solution Solved by Korben,

Recommended Posts


hey there,

first i did deploy the c2 server in a docker service based on alpine and the c2-armv8 version on raspberry pi, using clouflare tunnel to connect the service, which worked fine. no connection issues, all good.

then, after connecting the key croc it starts to "freeze" the server, will mean that every action clicking in the gui leads to spinning cirles and frozen homepage.

after a restart of the docker service and key croc (also firmware update to 1.4) it always leads to c2 server, which is not respndimg anymore after 20-30 seconds.

to eliminate docker as a possible source of this errors, i fired up the c2-armv8 binary on the raspi pi, which lead to the exactly same problems.

does anyone else use the 3.3.0 c2 server version on a armv[5-8] architecture ?



Link to comment
Share on other sites

its a Pi3, 4GB RAM, but in the meantime, i was able to reproduce the error even with an instance of C2 on windows 64-bit.

atm, im pretty sure its the croc, somehow its always after connect, executing random payload and after this, the server wont work properly anymore.

im also pretty sure, that after this the c2.db is in a corrupt state..

testing now with a fresh flashed key croc on version 1_4....

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...