Jump to content

SD card in Nano

Recommended Posts

Hi there everyone, its been a while since I used my NANO and I have had a few challenges getting it working.

The main one I am having problems with is getting the NANO to recognise and initialise an SD card.

Using Firmware 2.7.0

I have a 8gb SD card I put in the NANO and boot. if I go into the UI then I can format the SD card but it does not show up.

I have tried a couple of SD cards in different sizes and I have also deleted any existing partitions before starting.

I am open to any suggestions


Link to comment
Share on other sites

That looks fine....formatted ext4 and when I look on my raspberry PI it is mounted as /dev/sdc and I can see it in the file manager so I would say all looks good but its still ne showing up on the nano.....

Link to comment
Share on other sites

There have been issues over time "historically" regarding Micro SD card support for the Nano. I've never had any issues myself though and I have most likely used 10+ different card with different sizes. You could check logread/dmesg and try to find something that could tell what might be wrong.

Link to comment
Share on other sites

config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'5'
	option	check_fs	'0'

config 'mount'
	option	target		'/sd'
	option	device		'/dev/sdcard/sda1'
	option	fstype		'ext4'
	option	options		'rw,sync'
	option	enabled		'1'

config 'swap'
        option      device      '/dev/sdcard/sda2'
        option      enabled     '1'


Link to comment
Share on other sites

Things just got weirder. When I booted up the NANO and looked in the resources and I can see the SD card....

I went to modules and tried to install something onto it and I didn't get the install option and when I go back to resources the SD card is no longer there.


Link to comment
Share on other sites

Just done a reboot after removing the swap partition

Filesystem                Size      Used Available Use% Mounted on
/dev/root                13.0M     13.0M         0 100% /rom
tmpfs                    29.1M    164.0K     28.9M   1% /tmp
/dev/mtdblock3            1.3M    400.0K    880.0K  31% /overlay
overlayfs:/overlay        1.3M    400.0K    880.0K  31% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sdcard/sd1           3.6G     32.0K      3.6G   0% /sd

sd card seems to be there

I am going to try and install some stuff and see what happens

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...