Jump to content

Cant connect to c2

Go to solution Solved by dark_pyrro,

Recommended Posts

Hello so ive just got a brand new keycrock already updated everything fine but it cant connect to cloud c2 the wifi setup and everything seems to work the config file also doesnt show any problems what could i do in this situation? The lights which the keycrock shows are green for a few seconds then white for a few seconds then it goes abck to green then magenta for less then 4 seconds then Cyan for about 3-5 seconds if someone could help me that would be pretty nice

Link to comment
Share on other sites

16 minutes ago, hackerzero000 said:

updated everything fine

Just to be sure; you are on firmware version 1.4 then I assume


Do you have any other Hak5 devices that already is successfully connected to your C2 server?

If you ssh into your Croc, can you ping your C2 server from the Croc (assuming that your C2 server accepts ping)?

If you can't ping the server, what happens if you try to try to ssh into your C2 server using port 2022 from the Croc?

Are all necessary ports open on your C2 server?

Are you starting your C2 server using an IP address (or a domain name) that can be reached from the network to which your Croc is connected? (That IP address should of course also be the IP address where the C2 server is running)

If using a domain name, is that linked to the proper IP address using a dns A record?

Link to comment
Share on other sites

There's no need to check opened ports on the server if you have other devices that has successfully been connected.

1.4 is available here


Not sure it will solve your issue though. If you were using a domain name along with https/Letsencrypt, then it would probably fix things since there was a certificate issue in fw 1.3.

Instead of ssh, you can serial into the Croc when it's in arming mode.


Link to comment
Share on other sites

3 minutes ago, hackerzero000 said:

And from there hwo do i set up the crock for the c2 server?

Well, reading that sentence, it indicates that you haven't even tried to set it up for C2. If so, then it's not at all strange that it doesn't work. You need to create the C2 device.config file for the Croc and transfer it to the Croc file system.

I'd suggest that you read all of the documentation; both for the Croc and Cloud C2

Link to comment
Share on other sites

You shouldn't use ping like that, just ping and the IP address, i.e.


But, since you seem to use a VPS on Amazon, it won't respond to ping anyway (if set up using "defaults")

(And, don't post your real address, keep that to yourself just to be sure)

If you ssh, try; ssh root@<ip address> -p 2022


Link to comment
Share on other sites

The server responds in a way that should make it possible for the Croc to access the C2 server.

Since you have other Hak5 devices that are successful in connecting to your C2 server, I don't think there's anything wrong with the C2 server setup. And, in addition to that, it's obvious that the Croc can reach the C2 server.

I would probably check the cc-client error log in /tmp (if any) and also try to run cc-client manually with the path to the device.config file as a command line parameter.

Also check that the device.config file actually has been placed in /etc

I would probably also verify that the port and the IP address is correct in the device.config file

Link to comment
Share on other sites

The udisk is just the part of the Croc file system that is exposed/mounted to the device it's connected to when in arming mode (or ATTACKMODE STORAGE). To access /etc you need to either ssh into the Croc or connect to it using serial.

However, I just remember that the Croc handles the device.config a bit different than other Hak5 devices. The croc_framework stores the file in /etc but is actually using the one on the udisk, so try

/usr/bin/cc-client /root/udisk/device.config


/usr/bin/cc-client /root/udisk/device.config &

(to start it in the background)

Link to comment
Share on other sites

So when i try this the output is: root@croc:/# /usr/bin/cc-client /root/udisk/device.config
terminate called after throwing an instance of 'std::runtime_error'
  what():  CC-Config does not exist at the path given as argument
Aborted  : So i triedgoing path by path and there is no such thing as a cc-client what there is though are lots of files and the files C2EXFIL and C2NOTIFY what does that mean? Is there any way i can install this cc-client on the Keycrock?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...