Jump to content

Can't Flash the Pineapple


Recommended Posts

I've just received my Pineapple. I've plugged it, with USB on my computer.

I went to the address: and started the initial setup, and first surprise, I can't connect to my wifi network even though I typed the password correctly.

So I tried to go with the upload a file option, upload the firmware: 2.1.3 that I've downloaded on the site indicated by the web UI. So I tried another time to upload the firmware by clicking upload again and got the following error: fork/exec /usr/bin/splitweb: cannot allocate memory.

I tried with following versions of the firmware: :
- 2.1.3
- 2.0.0
- 1.0.0
- 1.1.1
And I got the same error each time. 

I've tried to reset it with the recovery image, and it succeded (by following the video tutorial on the official doc) but I still have the same error.
Can anyone help me please?

Link to comment
Share on other sites

I use the  USB-C cable that came with it, I tried on a linux ( arch ), I also tried on my MAC but, on this device the I can't access to  because I think that the mac hasn't recognize the device properly.

Link to comment
Share on other sites

Mac will not work if you are using later versions of MacOS. The ASIX driver is crap.

If you do a factory reset and can't connect the Pineapple to any AP/wireless network, then you could try to factory reset (again) and NOT at all try to connect to any AP, but instead upload the latest available firmware manually using the web UI of the Pineapple (i.e. download the upgrade file to the PC connected to the Pineapple, verify its SHA256 checksum, upload it to the Pineapple using the web UI during setup after factory reset).

Link to comment
Share on other sites

  • 1 month later...

Im Writing here this Step by Step because i have tried several times to Reset the device and by uploading the latest Firmware at the Setup menü i get a Flash error. It did work a while but since then..

Step 1: Factory reset the Firmware as in Manual told.


Factory Reset..

Step 2: Put the IP back to Normal again.

Step 3: image.png.daf57297711b63e66f61ce3f11363f7f.png

In this case i put have tried the 1.0 and it works. 2.0 does not and all others. 2.1...

Trying to Automatically update the Firmware over WIFI does load the newest.. and crash.


image.png.27f344b28abbeaaf818657a59d11ade6.pngTherefore i load not the 1.1.1..

But at 2.0 it crash.... what can i do?

With 1.1.1 it works..

After that updating into:




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...