Jump to content

OMG Cable Drivers for Linux / Wont Flash


jo3yy
 Share

Recommended Posts

Please bear with me here as I am very very frustrated with this. I have attempted to install the drivers on Ubuntu, Fedora and Debian. None of them install. I have tried to flash anyways without installing the drivers, this is what happens:

<<< FATAL ERROR: [Errno 13] could not open port /dev/ttyUSB0: [Errno 13] Permission denied: '/dev/ttyUSB0'. PLEASE DISCONNECT AND RECONNECT CABLE AND START TASK AGAIN >>>

 

I have tried the web flasher too and it does something similar.

I realize that it isn't the fault of the OMG programmer or cables that the drivers don't work, but the fact that this is a known product means that I know someone out there has to have figured out how to install the drivers on Linux based OSes. The drivers will not install, no matter what I try. I have looked it up, there are no solutions online. I have tried running make in the directory of the drivers, tried doing the necessary steps like cping some stuff, etc. It doesn't work. I am almost at tears here because this is so frustrating, it should not be this hard to install a driver! I need an easy solution because I do not want to have to troubleshoot this anymore. I'm already frustrated.

Link to comment
Share on other sites

I am stupid.  On Debian and Ubuntu I just needed to reinstall pyserial as root and run it as root. On Fedora, there were actual driver problems, they didnt' seem preinstalled. Please delete this thread if spotted.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...