Jump to content

Not able to upload packet captures to the C2 instance.


NightStalker
 Share

Recommended Posts

Hello all, I have a C2 instance on the public internet and its reachable via the PS when in arming mode. The issue is when I run C2EXFIL I am getting an error  and I cannot find any information on it specifically on the forum and the net. Any help is appreciated.

The error I get is:

root@squirrel:/mnt/loot/tcpdump# C2EXFIL /mnt/loot/tcpdump/dump_2022-02-07-180824.pcap
Starting C2 Exfil Tool
Configuring C2 Connection
Preparing Loot for Exfiltration
Loot Path: /mnt/loot/tcpdump/dump_2022-02-07-180824.pcap
Sending Loot to C2
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
Aborted

 

I get the same error no matter if I am in arming mode or switch1 mode with the PCAPs dumping to the SD card. (See attachment from C2 server)

ps_exfil_c2.jpg

Link to comment
Share on other sites

Never seen that before on the PS. Is there any lack of storage space on the USB storage device? Tried some other USB storage device (in case it is corrupt in some way)? Could be problems to allocate RAM, but I've seen it along with gparted where corrupt storage devices seems to have been the problem.

Edited by dark_pyrro
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...