Jump to content

Pineapple MARK VII: Failed to obtain modules error


Recommended Posts

Hi guys. I setup my pineapple and the features and tabs such as recon, campaign etc work..

but when I attempt to install the modules I get an error

“Failed to obtain modules. Please check your internet connectivity settings.”

it also says the same connection  thing when I click “check for updates”


I’ve tried connecting using the ICS method   Pineapple is plugged into computer.  I’ve even ran “opkg update” in the terminal to see if it would connect but the download process failed   

WiFi pineapple mark vii 
windows 10  I also tried it on a second windows 10 computer and had the same problem  

What could i be doing wrong?



Link to comment
Share on other sites

9 hours ago, Jtyle6 said:

Or you could `ping` or `ping`

The WiFi connection isn’t hidden but it’s good to know so thanks for catching me up to speed on that. 🙂

I pinged the above addresses

And got nothing 

then I set the wireless client to connect to the “management access point” and tried again 

google said bad address said 56 data bytes did nothing. 

This is indeed a bit of a nightmare but I’m enthusiastic about getting it figured out.  Thanks for the help!

i wonder what else could be causing this...

Link to comment
Share on other sites

So I tried various other WiFi connections, no luck 


but then I changed to a diff usb cord that’s plugged into the wall instead of into a pc, connected it to a mobile hotspot while accessing it from its management connection and now it works.  

not sure which of the above fixed it but it’s working for now 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...