Jump to content

Filter Settings do not work on the MK VII


Recommended Posts

I believe that I have discovered that the filter settings on this version of the pineapple simply do not work.  I spent the entire day today testing this.  Adding anything to the client list as ALLOW is equivalent to disallowing it; meaning that anything you add to this will not be allowed to connect to the network.  If you provide a MAC address and put it on the client list to DENY, that client will forever still be allowed to connect.  

Following the tutorials for this device simply do not work;  Factory resets, reflashing firmware, will not resolve this issue.  It appears to be impossible to capture traffic without capturing EVERYTHING FROM ALL NETWORKS.

I believe that Hak5 knew about this issue, which is why if you watch their tutorial, the only instance they show of capturing traffic is when they set both filters to deny, which it seems,  is the only way to actually capture traffic with this device.


Link to comment
Share on other sites

I'm also having some issues - but I'm not sure it's the Pineapple filter settings or the devices I'm trying to connect. So far, the only devices that I have been trying to connect to the open AP are my phone and tablet - both of which (by default) randomize their MAC addresses. I did disable that option, and captured the MAC addresses on the Pineapple - then putting that address in the filter table. 

When I set that table to the "Allow" option, I am unable to connect with them. When I toggle to the "Deny" option, I can then connect - but so can anyone.

So it appears to me at this point that the "Allow" filter is not working.

(BTW - I do not have any entries for the SSID filter column and it is set to the "Deny" option)

Link to comment
Share on other sites

I must confess that I am having issues too. I have set up an Evil Portal, downloaded and installed the portals and found them successful (except for a denied authorization but will play with that later.)

After having successful portals coming up on my device, I then systematically tried all variations of the filters (Client and SSID). The only way I could connect with my device was with everything set to allow. The successful connections were used to verify the MAC, I copy pasted my SSID from the logs to be sure as well.

The question I have for the Hak5 team, is it working for you and I am doing something wrong? Or, is this a known bug that will be fixed in the future. A quick verification would be very helpful so I don't keep pounding my head against this wall. LOL. (which I am very prone to do)

We were looking to purchase a slew of these for educational purposes. Being able to narrow the engagement would be very healthy. 🙂

Thank you so much for all you folks do.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...