Jump to content

Can't SSH from C2 to any device


Recommended Posts


So, been setting up my devices in C2. Got all of them in there and I can see the Loot as well as other items like say the Pineapple Tetra's SSIDs and such.

One thing I can't seem to do is SSH from C2 to any device. 
I was wondering if I'm missing something specific on my setup. I have even tried setting SNATs to the devices, though I knew that wouldn't have been a requirement nor really worked... But I went that far as I just couldn't figure it out.

It would really help me if I can get this sorted as I have a Pen Test coming up and I'm foreseeing the need to drop some of the devices on site. 
A work around is dropping a Raspberry Pi or something with them, but it does add an additional device.


Link to comment
Share on other sites

  • 2 weeks later...

Hey VB

I can say that it's open.

To go into detail:
Server is in Azure. The Firewall in Azure allows any incoming traffic over 22 and 2022 to hit that VM. Also, this is the only VM in that NSG.
The device is connected behind a Watchguard Firewall in my lab at home. The Firewall allows it to go out on 22 and 2022 (as well as a few other ports for testing).

Obviously, there is no incoming SNAT setup as it should be required on the Watchguard/LAB Firewall.

I hope that helps.
Thanks for answering though!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...