Jump to content

Cant Connect Devices


Vulcan22
 Share

Recommended Posts

I am pulling my hair out, i can't seem to connect any Hak5 device to cloud C2. I have tried the Lan Turtle, WiFi Pineapple, Packet Squirrel, Shark Jack and Signal Owl and none of them connect. I run...

c2-2.1.2_community_amd64_windows -hostname c2 -sshport 80

and have tried many variations of this. At the moment I am running it on windows but I have tried running it on Kali Linux, a Raspberry Pi and a VPS. I download the device.config file and scp it to /etc/ and when I run C2CONNECT this happens...

C2CONNECT.PNG.5c6ebd3c2127e621d1e955783dc304ee.PNG

(I am using the Lan turtle in this example, but all the devices are similar). It seems to be connected, but on Cloud C2 it doesn't show up. I tried running it with a domain and in -https mode and that didn't do much. I don't have the slightest idea of what the problem is. I have tried running cloud C2 on different networks and different devices at different places and don't see how this is possible. I am obviously doing something wrong. If anyone can help me or has any advice on how I would go about fixing this it would be greatly appreciated XD.

Link to comment
Share on other sites

Hi Treebug,

You really shoudn't be using port 80 for SSH as this port is used for HTTP. SSH is normally on port 22 (and for C2 2022). I would remove the "-sshport 80" and rerun your script. Your devices are trying to communicate via port 2022, but you're only listening on port 80, hence why C2 can't communicate and vice versa.

Refer to my guide if you need a better understanding. Happy belated X-Mas! 

Best,

VB

Edited by Void-Byte
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...