Jump to content

Connection sharing issues - Kali


Recommended Posts

Hello guys,
First of all I want to say hi as I'm new to forum and WP. I also want to mention that I looked for the help in other topics but unfortunately was unable to overcome my issue.

I have a problem with connection sharing (I have access to internet, however nano does not - impossible to load bulletins). I used the script and it worked the first time. After I left nano scanning for a few minutes the connection was gone. Client mode works fine. Using the script again did not help. Adding new default routes to Kali did not help. Factory rested did't as well. I don't know how to resolve this...

My system info: 
Kali Rolling edition (not vm)
nano: v 2.5.2
script: wp6.sh

route on kali outputs:

Destination        Gateway        Genmask            Flags    Metric    Ref    Use    Iface
default                _gateway                UG         600         0      0         wlan0          U           600         0      0         wlan0      U           100 .       0      0         wlan0

ip route:

default via dev wlan0 proto dhcp metric 600 dev wlan0 proto kernel scope link src metric 600 dev eth1 proto kernel scope link src metric 100


Wp6.sh configuration:

Saved Settings: Share Internet connection from wlan0
to WiFi Pineapple at eth1 through default gateway

(nano is indeed on eth1) ifconfig on eth1:

inet netmask broadcast

also from management page:
Networking tab > route 

Kernel IP routing table
Destination 	Gateway			Genmask			Flags	Metric	Ref		Use	Iface
default			UG		0		0		0	br-lan		*	U		0		0		0	br-lan


"upadte route" shows in grey:

Please help me deal with this...
and sorry if something's stupid happening, I'm still a learner. let me know if more data is needed. Thanks!


Link to comment
Share on other sites

  • 2 weeks later...

Okay, so just for the other people with this problem: It was caused by wrong auto-configuration of route nano was listening on. Going to networking tab and setting the default route to solved the problem. Just make sure that in Kerner IP routing table in nano management networking tab you have the same route as your os outputs on "ip route" command (eth1 (or whichever you use) src value)
Hope this helps someone


thx to Poshmagicode

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...