Jump to content

AutoSSH - connection refused


ccko
 Share

Recommended Posts

Ive followed the video and multiple walk throughs and have read a dozen or so forum topics here to no avail. Using a digital ocean VPS running fedora, iptables with port 22 open. According to netstat the turtle is getting into the vps but 'ssh root@localhost -p 2222' gives me connection refused. Does iptables need some kind of port 2222 exception even though it's local? Any other ideas welcomed!

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Hello everybdy

im blocked with the configuration of autossh,  i m trying  to connect on my Lan turtle from my ftpserveur ((my nas is ftpserver)) to my turtle, i have an massage like this : 

first, you have to know 

i haver ever configured keymanager and create key, copey key to my nas ( who is ftpserver)

i have ever configured autossh and my remote port is the number 2222 and my local port is 22

my configuration autossh  is :

[..]

option poll '600'

option ssh '-i /root/ .ssh/id_rsa -N -T -R 2222:localhost:22 myuser@IpadressePublicOfMyRooter  -p 2222'

[....]

 

 

well i connect to my server nas with root utilisateur 

after that i try to onnect on my  Lan Turtle with : ssh root@localhost -p 2222

but i have a message error  like this :  ssh : connect to host localhost port 2222 : connection refused

 

have you had this problem ?

have you got an idea ?

 

thx

 

 

 

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...