Jump to content

[SOLVED] wireless clients cannot connect to internet, pineapple can, ethernet client can

Recommended Posts

So I have an external wifi card -- AWUS036NH -- and it shows up on wlan2 and gets an IP address just fine.  Pineapple can ping out (via root ssh) and laptop with wifi disabled can connect to the internet via an ethernet connection to the pineapple.


However, my phone picks a wifi connection broadcast by pineapple (the unencrypted version of a near-by encrypted hotspot) and the phone gets "no internet connectivity" message.  Edit:  Interesting fact, pineapple shows "0 clients"?  Also, wlan1 looks like it's unchecked and checking it then pressing refresh causes it to be unchecked again?

I also see in the log for PineAP that the mac of my phone is trying to assocaiate with an SSID in the SSID Filtering list (with SSID Filtering in Allow mode)

Client filtering is in "deny" mode and the list is blank.  Maybe that's my problem?

Any thoughts?

Edited by shadesoflight
note about clients not showing as connected. note about log for probe request & trying to associate
Link to comment
Share on other sites

Fixed.  It was my OnePlus One having problems in Cyanogen Mod 13.1 -- an OTA applied using FlashFire both preserved my apps, root, and fixed my wifi.

Additionally, it might have been confusion surrounding ALLOW and DENY modes in Karma filters:

Allow Mode:  This is a whitelist.  A whitelist implies that _any_ mac ID not on this list cannot conenct to the pineapple

Deny Mode: This is a black list -- and is defaulted to every time my MK5 reboots.  The blacklist means that _any_ mac ID that tries to connect to the pineapple will only be denied if it shows up in the list.  

I'm still not sure about SSID allow/deny -- I imagine that probe requests and attempts to authenticate to an SSID in the blacklist (when in DENY mode) will simply not be responded to by the pineapple.  And likewise, probes and auth requests to SSIDs not in the whitelist (when in ALLOW mode) will be ignored.

Edit:  Even if you think you understand ALLOW and DENY modes, if your device is having trouble connecting then just check the existing lists that you have.  You might have added something to the list and then knowingly or unknowingly switched the mode.

Edited by shadesoflight
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...