Jump to content

Airodump-ng not logging --wps and --manufacturer data


flonkyplonk
 Share

Recommended Posts

Hey all,

Over SSH, when running airodump-ng with the --wps and --manufacturer flags, the status of both appears on screen during the live capture, but I cannot find this information anywhere within the .csv and .xml data logged. That leaves the .cap files, obvs but I'm a bit noob and haven't dug into them - also, alot of the cap files I get seem corrupted, perhaps due to a lot of weak signals when wardriving?

Has anyone had any success with logging this data for later analysis, really scratching my head here. I tried to ask about this on the aircrack-ng forums a couple days ago but the mods havent put the question up so I figured someone here may have experience of this?

TIA

Link to comment
Share on other sites

Been looking at this a bit more. I have managed to output the WPS data by using wash -o <outputfile> instead of airodump-ng - though this still leaves the issue that the manufacturer is not being reported. Wash has a manufacturer reporting switch but havent got this working yet...

Wash seems a little out of sorts on openwrt arch - as others have said, any tips on optimising it's performance?

Also, still very keen to find out more about airodump-ng options, as it is my tool of choice and I can't fathom why it wouldn't log out some things it reports on screen?

Link to comment
Share on other sites

>>What would you like to see performance-wise in wash?

Oh, nothing, was on the wrong track with Wash - thought it wasn't updating the signal strength readout on the screen like airodump-ng does (for zero'ing in on access points) but have since run it on Kali and have realised it is a limitation of wash not Pineapple implementation.

Looking into this further it seems kismet does most of what I want, but I can't get kismet to recognise the OUI file (manufacturer description) I have dropped on the SD card - it finds it, but reports 0 lines, have tried this with two different OUI files.

Also, can't seem to get a kismet client to connect to the kismet server on pineapple (which is sensational btw)

So current question(s) anyone got advice on getting device manufacturer to work on pineapple in kismet-server, and any tips on getting external kismet client to connect to kismet-server on pineapple (I am running kismet from a kali vm, have added the subnets to the allowed list, but it just reports connection refused)

Thanks all!

Link to comment
Share on other sites

  • 2 weeks later...

Bump for interest!

I can dump the WPS status to a log with wash, but what I need is the wps status and the chipset used - both of which are reported by airodump-ng, just not dumped to file.

Anyone? Anything?

If it helps to remedy my stupidity - kismet-server dumps the manufacturer in the xml output, but my regex kung-fu resembles elderly pub fighting, and I can't into tying the data together without it all, being on the same line!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...