Jump to content

Burpsuite and SE toolkit wont intall


Recommended Posts

Ok so i just got my first rubber ducky in the mail today. I install the newest version out today of the duckencoder when i run the dependency install it will not install burpsuit or SE toolkit. It will say they are installed but they always show up as not installed no matter how many times i run it. I tried to use the encoder but it will not use the encode.jar file and I believe its because of those two dependencies

[+] APT Update complete...

[*] Please wait while I install some dependencies...


[+] pure-ftpd is already installed on your system, moving on...

[+] file-roller is already installed on your system, moving on...

[+] dfu-programmer is already installed on your system, moving on...

[+] apache2 is already installed on your system, moving on...

[+] gnome-terminal is already installed on your system, moving on...

[-] It doesn't appear that burpsuite is installed on your system. Installing it now...

apt-get: /usr/local/lib/liblzma.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12)
E: Unable to locate package burpsuite

[!] It doesn't appear that I will be able to install burpsuite right now.

[+] git is already installed on your system, moving on...

[+] wget is already installed on your system, moving on...

[+] netcat is already installed on your system, moving on...

[+] p7zip-full is already installed on your system, moving on...

[+] nautilus is already installed on your system, moving on...


[*] Checking to see if Metasploit is installed...

[+] Good news, Metasploit installed without any issues.

[+] Checking to see if the Social Engineering Toolkit is installed...


[-] It doesn't appear that the SE-Toolkit is installed on your system. Installing it now...

Cloning into '/tmp/simple-ducky/set'...
remote: Reusing existing pack: 45750, done.
remote: Counting objects: 321, done.
remote: Compressing objects: 100% (321/321), done.
remote: Total 46071 (delta 180), reused 0 (delta 0)
Receiving objects: 100% (46071/46071), 97.82 MiB | 625.00 KiB/s, done.
Resolving deltas: 100% (29635/29635), done.
Checking connectivity... done.
apt-get: /usr/local/lib/liblzma.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
git is already the newest version.
python-crypto is already the newest version.
python-openssl is already the newest version.
python-pefile is already the newest version.
python-pexpect is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[!] SET is already installed in /usr/share/setoolkit, remove and start again.

[+] Good news, the SE-Toolkit installed without any issues.

Trying a different approach to install Burpsuite...


mkdir: cannot create directory ‘/usr/share/burpsuite/’: File exists
--2014-07-14 18:36:46--  http://portswigger.net/burp/burpsuite_free_v1.5.jar
Resolving portswigger.net (portswigger.net)... 54.246.129.208
Connecting to portswigger.net (portswigger.net)|54.246.129.208|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6901614 (6.6M) [application/java-archive]
Saving to: ‘/usr/share/burpsuite/burpsuite.jar’

100%[=========================================================================>] 6,901,614    694KB/s   in 15s    

2014-07-14 18:37:02 (452 KB/s) - ‘/usr/share/burpsuite/burpsuite.jar’ saved [6901614/6901614]

ln: failed to create symbolic link ‘/usr/bin/burpsuite.jar’: File exists

[+] Good news, Burpsuite installed without any issues.

[+] Checking your JDK version, I will update it if needed...


[+] It looks like your JDK is up to date, moving on...

[+] The installation process is complete! Returning to the main menu...
 

.

Link to comment
Share on other sites

  • 3 weeks later...

Try creating a simple duckyscript with the online duckencoder and see if you can get that to work. The duckencoders seem to fail a lot more than the online one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...