Jump to content

Losing connection to Pineapple after short period of time


xakcop
 Share

Recommended Posts

I have a brand new Pineapple Mark V purchased from Hakshop and I can't use it for more that 5-6 minutes. It boots normally, the web interface is available, I can ssh into it but after a few minutes it becomes inaccessible. I cannot ping it (172.16.42.1) and the AP is gone. It is like something happens with the network devices on the pineapple because the amber led goes off for about 6-7 seconds and when it comes back I cannot access it anymore. I am using an AC adapter, not batteries.


I have tried versions 1.2, 1.3 and 1.4 of the firmware and I get the same behavior with all of them. I bought a new SD card (SanDisk class10 8GB) and still no luck. I am out of ideas how to debug this thing.


These are the syslog messages and dmesg that I capture before I get disconnected:






Any ideas what else I can try? Any help is much appreciated.

Link to comment
Share on other sites

It happens even if I don't install any infusions and just connect to the AP and start browsing.

I think that if I start using karma or sslstrip I just got disconnected faster but I am not very sure if this is always the case.

Link to comment
Share on other sites

Look at your logs see if it says you were deauth because of inactivity.

Mine does that, if it does let Sebkinne know.

Here may be another Sebkinne. Now maybe 3 of us?

Edit: after looking at your logs.....it doesn't seem to be whats happening to me.

But what you describe it's exactly what happens to me......... 10 minutes tops and nothing can connect via wifi.

Edited by xrad
Link to comment
Share on other sites

Not a thread hijack... I see something similar while at work using the WiFi network (wlan1 in client mode).

WiFi Pineapple configures and connects fine to the WiFi access point at work and things are peachy. Then randomly, sometimes after 10 minutes, sometimes an hour, sometimes a couple of hours... I cannot access the Pineapple via the client WiFi connection. It does not ping, no HTTP access, no SSH. The red LED is off.

BUT...any client(s) connected to the WiFi Pineapple wlan0 AP radio seems to be fine. They have internet access though the Pineapple AND can access the WiFi Pineapple web management page. Not sure what is going on here when this happens.

Restarting the WiFi Pineapple OR the work WiFi access point providing the internet access brings things back to life. I haven't noticed this on any other WiFi client device I use at work. This behaviour has been consistent through three firmware revisions.

I don't have this problem at home using my Minitar UltraWAP WiFi access point, I can stay connected for days!

I will try to get some logs next time.

Lunokhod

Link to comment
Share on other sites

You can look in the log tile.....

If you see " deauthenticated due to inactivity" which is the problem I have, I'm testing this today,

Post # 11 from this thread

https://forum.openwrt.org/viewtopic.php?id=27953

I have only been testing for a short time, so I'm not sure if it has fixed my problem, but so far it seems promising.

If you are not getting any "deauthenticated due to inactivity" in your logs, ignore this post

Edit: NO Luck..........it didn't help :(

Edited by xrad
Link to comment
Share on other sites

Ok I have had mine mark 5 for less than three days and I am seeing this same issue though it appears to be erroring because the red light goes solid along with a solid green(power) light and a sporadic flashing amber. then amber and red stops and the blue light starts flashing like it is booting back up. I am cabled in through the the ethernet and have the wifi connecting to a g style network I have saved to it for the moment. I did go ahead and install all the infussion this last firmware reset which mind you is the third time I have flashed the firmware for doing the same thing. Not all times have I hade the infussions loaded. I am using both puttytray and mozilla to access both interfaces trying to monitor top and now htop that I got loaded on it before it died. I have tried rebooting through the gui which did seem to resolve some lag issues I had previously wile using the browser interface. Prior to finding that link for restart I was using halt to stop the device. I am willing to try and work out this bug but I am a bit disappointed in having the device for 2 days and it is rebooting almost every 60 seconds. I am a bit new to openwrt. What info would you like logs reflash and monitor take it apart and check for overheating since the resources in the monitors and looks green accept mem holding at something around 63%. CPu usage is real low in top and htop. Box feels a little warm to the touch. Anybody know if I take it appart if I will void it. I got some decent thermal paste on hand and some old pac parts maybe I can diy a heatsink incase that is the issue.

Any suggestions or requests?

Link to comment
Share on other sites

  • 3 months later...

Hi all

Any progress on this issue yet? I seem to suffer from the same issue (see https://forums.hak5.org/index.php?/topic/33591-help-stability-issues/). I also contacted Hak5 via their web form about a week ago. No response whatsoever ☹ Feeling a bit of buyers remorse coming up :-(

If any of you solved their issue, please share your solution.

Thanks!

Rob

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...