Jump to content

Kali Linux & BT5 VM and USB woes?


nicron
 Share

Recommended Posts

Hi Folks,

Been playing catch up on this show and after watching episode 519 I thought I would try a VM of Kali or BT5 to try pen testing. Unfortunately I can't get the USB WiFi device (atheros chipset) to be seen by the VM (using VMware Player or Virtualbox) like Darren shows in the episode.

I have read and research over the web and found this to be a problem for others as well.

i.e. https://forums.hak5.org/index.php?/topic/29374-backtrack-5-usb-wi-fi/?hl=virtualbox

and https://forums.hak5.org/index.php?/topic/29546-usb-wifi-on-virtualbox/?hl=virtualbox

My question is does anyone know what version of VirtualBox Darren was using in the episode? (I know been some time). Figured it was worth trying that version of virtualbox...

I purchased an Alfa (enroute) but I don't see the problem resolving with a different device.

Others have suggested I just install Kali Linux on a USB and boot into it from that. But I have found v4 and v5 (1.04 and 1.05) both to be problematic with trying to install onto a USB flash drive. Problems keep occuring with the Ext4 and partition table writing.

About to try the same approach with BT5R3, but does anyone have any other suggestions?

Thanks

Link to comment
Share on other sites

docs.kali.org and I have never had an issue with a VM not seeing a USB device in VMware, just make sure its set to be enabled when plugged in under the settings before boot, and don't insert the card until after booted and in the desktop terminal, then run dmesg before, and after you insert it to see if its seeing the device.

For compatible wireless cards: http://www.backtrack-linux.org/wiki/index.php/Wireless_Drivers#Tested_and_working_cards

Link to comment
Share on other sites

i51XxQV.png

This is how I have my VM setup (make sure the bios on the HOST machine, not VM, has USB 2.0 enabled and virtualization capabilities as well as the settings above!)

Once logged into the VM, start the desktop, and then open a terminal. Type dmesg. Then plug in the USB device, and type it again and see what changes. If nothing, in the bottom right corner of VMware, click where the log and other devices are and tell it to connect to the VM. If that doesn't work, you have some other issues going on as it should be seen. You can do lsusb in the virtual machine too, to show connected devices, but windows(or linux) should pass the device to the VM, and if it doesn't you can tell it to afterwards, which I do with my one linksys USB wifi card since I use it on both windows and VM's it sometimes starts up under windows and I have to disconnect from host and connect it to the VM.

Link to comment
Share on other sites

Thanks.... so I have tried a number of times with Virtualbox, and have tried now with VMPlayer. At least with VMPlayer I can see part of the issue and that is the fact the Windows still has access to the device TPLink WN722N. So silly question, how do release it from windows by enable VMWare to see it?

edit...

Nevermind I figured that out with VMPlayer from the menu screen. I will play with that and let you know the result..

Thanks again

Edited by nicron
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...