Jump to content

Issue with DNS spoof


flagellum
 Share

Recommended Posts

Excuse me if this has already been answered, I lurked around but I didn't find anything that answered my question.

DNS spoof seems pretty straight forward. Right now the only entry I have right now is:

172.16.42.1 *facebook.com

This works, and takes me to the index.php landing page. Unfortunately however, it does this for EVERY URL, not just pages with the facebook.com domain in them. I've tried messing with this in different ways but it redirects there regardless. I've tried doing a DNS flush and restarting and reconnecting my victim machine.

Has anyone else had this issue?

The goal is to only redirect to the index.php landing page when facebook.com is entered.

I am using 2.8.1

Edited by flagellum
Link to comment
Share on other sites

can you run a nslookup of facebook.com from one of the clients?

Double check your dnsspoof config file is correct by cat'ing it over ssh.

Should be:

172.16.42.1    *.facebook.com

Don't think the extra '.' would make much different but add it in anyway

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...